Ask Your Question
2

Fedora stageros rosmake - undefined reference

asked 2012-07-27 06:33:12 -0600

user12821821 gravatar image

updated 2012-07-27 08:28:41 -0600

Hello, trying to install stage on a working ROS (fuerte) install (verified through all tutorials), but at some point when I try to rosmake:

/usr/bin/ld: CMakeFiles/bin/stageros.dir/src/stageros.o: undefined reference to symbol '_ZN2Fl4waitEd' /usr/bin/ld: note: '_ZN2Fl4waitEd' is defined in DSO /lib/libfltk.so.1.3 so try adding it to the linker command line
/lib/libfltk.so.1.3: could not read symbols: Invalid operation collect2: error: ld returned 1 exit status
make[4]: * [../bin/stageros] Error 1

No problems with rosdep either.

I thought this was related to this ticket, but shouldn't this be fixed? https://code.ros.org/trac/ros-pkg/ticket/4441

Thanks so much for any help!

edit retag flag offensive close merge delete

Comments

I don't know the answer, but what version of ROS you're working with will be important to answering the question.

Asomerville gravatar imageAsomerville ( 2012-07-27 08:18:02 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-27 08:54:52 -0600

joq gravatar image

updated 2012-07-28 06:51:29 -0600

On Fedora, that reference is supposed to be satisfied by installing fltk-devel.

What does this do?

$ rosdep install stage

UPDATE: try this, then check to see if the fltk package named is actually installed:

$ rosdep resolve fltk

UPDATE2: that #4441 fix was to an older version of stage (3.2.2). Fuerte has stage 4.1.1.

I can't tell whether or not that fix was ever applied upstream. It may have gotten lost in the version upgrade.

I recommend opening a new ticket for Fuerte, referring back to #4441 and to this question.

edit flag offensive delete link more

Comments

When I do "rosdep install stage" I get the message: "#All required rosdeps installed successfully" then when I retry rosmake I get the exact same error.

user12821821 gravatar imageuser12821821 ( 2012-07-27 09:59:39 -0600 )edit

When I do "rosdep resolve fltk" I get the message: "#yum" followed by the message "fltk-devel" , when I retry rosmake I get the exact same error.

user12821821 gravatar imageuser12821821 ( 2012-07-27 11:15:27 -0600 )edit

Does yum say fltk-devel is actually installed?

joq gravatar imagejoq ( 2012-07-28 04:25:14 -0600 )edit

When I do yum list installed I have entries for : "fltk.i686", "fltk-devel.i686", "fltk-fluid.i686" and all of these three have a version of 1.3.0-4.fc17 thanks so much for your help btw it is greatly appreciated.

user12821821 gravatar imageuser12821821 ( 2012-07-29 06:38:54 -0600 )edit

Okay thanks so much for your help, submitted a ticket #5507

user12821821 gravatar imageuser12821821 ( 2012-07-30 06:39:51 -0600 )edit
1

answered 2013-01-28 16:19:23 -0600

For anyone still having issues, this patch fixes things for fedora: https://code.ros.org/trac/ros-pkg/attachment/ticket/5507/fltk-find-package.patch

edit flag offensive delete link more

Comments

Thanks for the update!

user12821821 gravatar imageuser12821821 ( 2013-03-07 07:19:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-27 06:33:12 -0600

Seen: 580 times

Last updated: Jan 28 '13