Ask Your Question
0

ROS RGBD SLAM Problem

asked 2012-07-26 10:59:10 -0500

Tahir gravatar image

updated 2014-01-28 17:13:09 -0500

ngrennan gravatar image

Hi I am using ubuntu 11.10 with ROS electric and Kinect.

when i run the application, it works fine in pause state. Upon processing, it results in exit with following message.

bool g2o::HyperGraphActionLibrary::registerAction(g2o::HyperGraphElementAction): creating collection for "writeGnuplot" bool g2o::HyperGraphActionLibrary::registerAction(g2o::HyperGraphElementAction): creating collection for "draw"

(rgbdslam:2800): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rgbdslam:2800): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rgbdslam:2800): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(rgbdslam:2800): Gtk-WARNING *: Unable to locate theme engine in module_path: "pixmap", [rgbdslam-1] process has died [pid 2800, exit code -11]. log files: /home/vision-lab/.ros/log/fb3c4690-d763-11e1-aad7-f80f4113f0b0/rgbdslam-1.log all processes on machine have died, roslaunch will exit shutting down processing monitor... ... shutting down processing monitor complete done

Please tell what is missing and why I am getting this reply.

edit retag flag offensive close merge delete

Comments

It works good with roslaunch rgbdslam kinect+rgbdslam.launch

Tahir gravatar image Tahir  ( 2012-07-26 11:11:05 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-30 06:32:38 -0500

The only relevant information is this:

[rgbdslam-1] process has died [pid 2800, exit code -11]. log files: /home/vision-lab/.ros/log/fb3c4690-d763-11e1-aad7-f80f4113f0b0/rgbdslam-1.log

Signal 11 roughly means that a memory segment is accessed that doesn't belong to the process. You probably need to run it in a debugger to get to the source of this error.

How do you start it? A standard launch file? A custom one?

edit flag offensive delete link more
1

answered 2012-07-28 01:47:36 -0500

Yum.my gravatar image

sudo apt-get install gtk2-engines-pixbuf

hope this helps...:)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-26 10:59:10 -0500

Seen: 453 times

Last updated: Jul 30 '12