ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

map/ Control loop missed its desired rate of 5.0000Hz

asked 2022-04-15 15:54:42 -0600

MiPlayer gravatar image

updated 2022-04-17 11:18:33 -0600

Hello. I am using ros melodic and I am trying to do mapping and navigation. I am getting the following error:

I have already tried the suggestions in other posts with similar errors with no success. I am not sure what code I should send for debugging. Please let me know.

Edit: Here are the params that I am using:

global_costmap:

global_costmap: global_frame: map robot_base_frame: base_link update_frequency: 5.0 publish_frequency: 5.0 static_map: true transform_tolerance: 0.5 #1.0 plugins: - {name: static_layer, type: "costmap_2d::StaticLayer"} - {name: obstacle_layer, type: "costmap_2d::VoxelLayer"} - {name: inflation_layer, type: "costmap_2d::InflationLayer"}

local_costmap:

local_costmap: global_frame: map robot_base_frame: base_link update_frequency: 2 publish_frequency: 2 static_map: false rolling_window: true width: 2 #5 height: 2 #5 resolution: 0.1 transform_tolerance: 0.3

costmap params:

robot_radius: 0.19 transform_tolerance: 0.3 map_type: costmap obstacle_layer: enabled: true obstacle_range: 2.5 #2.5 raytrace_range: 3.5 #3.5 inflation_radius: 0.2 #.5 track_unknown_space: false combination_method: 1 observation_sources: laser_scan_sensor laser_scan_sensor: {data_type: LaserScan, topic: scan, marking: true, clearing: true} inflation_layer: enabled: true cost_scaling_factor: 5.0 # exponential rate at which the obstacle cost drops off (default: 10) inflation_radius: 0.2 #.5 # max distance from an obstacle at which costs are incurred for planning paths. static_layer: enabled: true map_topic: "map"

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2022-04-16 05:04:11 -0600

I encountered the same error and I solved it by increasing the value of the parameter transform_tolerance from the parameters of the costmap. Try increasing it by small increments and see if the problem persist, notice that a value too large could cause some problems because the data it get will be too old.

edit flag offensive delete link more

Comments

I messed around with the transform tolerance and it does not seem ot be improving. Do you have any suggested values I can try? (I edited my original post to include what I have)

MiPlayer gravatar image MiPlayer  ( 2022-04-17 11:22:21 -0600 )edit
0

answered 2022-04-15 18:48:43 -0600

bribri123 gravatar image

that is okay this does not affect much its just that it expected a higher or lower frequency but instead the frequency was higher/lower than expected you can change this so that the expected frequency is higher/lower in costmap params

edit flag offensive delete link more

Comments

I have been changing some of the params and I still seem to get the same error. Do you have any suggested values I can try? (I edited my original post to include what I have)

MiPlayer gravatar image MiPlayer  ( 2022-04-17 11:19:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2022-04-15 15:54:42 -0600

Seen: 87 times

Last updated: Apr 17