Ask Your Question
0

Gazebo initial view of world - my rendering:gui fltk tag is not working

asked 2012-07-26 00:45:58 -0500

dbworth gravatar image

updated 2012-07-26 00:53:19 -0500

Ubuntu 12.04 Fuerte Gazebo 1.0.2

Hi
The following posts describe how to set the initial distance/orientation of the static camera view when your Gazebo .world file loads:
http://answers.ros.org/question/11178/initial-view-after-gazebo-starts/
http://answers.ros.org/question/12658/how-to-change-gazebo-gui-focal-lengthfov/
using a block in your .world file like this:

   <rendering:gui>
    <type>fltk</type>
    <size>480 320</size>
    <pos>0 0</pos>
    <frames>
      <row height="100%">
        <camera width="100%">
          <xyz>0.3 0 3</xyz>
          <rpy>0 90 90</rpy>
        </camera>
      </row>
    </frames>
  </rendering:gui>

but it seems like this code is being ignored by my Gazebo.
No matter what parameters I change, Gazebo always loads with the robot model at the same distance and orientation. Its annoying having to zoom-in, unlike Rviz.

Is anyone able to change their default Gazebo camera view? @marcus-bader is this still working for you?

cheers.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-30 08:54:22 -0500

Hi,

I am using electric, Ubuntu 11.10, and above code works w/o a glitch. It might be possible that while launching gazebo it is reading these parameters from somewhere else as well. I guess gazebo takes the first value, in case there are multiple tags.

Kindly post your entire .world file and also how u r launching it.

Just curious, any idea what does fltk stands for, in type tag?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-26 00:45:58 -0500

Seen: 908 times

Last updated: Jul 30 '12