Reverse engineering the devel/

asked 2022-03-11 18:22:19 -0600

aarsh_t gravatar image

Hello everyone,

I don't know if I have titled the question correctly or not, please read the text for details.

I wanted to know if is it possible to build the catkin workspace by just having the folders of the devel folder?

Like we have something similar in the devel folders of the workspace as the main /opt/ros/$distro folder. So I wanted to know if is it possible to extract the info from that devel folder or create the local workspace just from it?

I have one pkg(rather I would say after-build devel folder) which has include/ lib/ share/ And I want to create proper workspace outof it. I tried sourcing the and also creating setup.bash and modifying the but it is not sourcing and ros is unable to detect the path

I know its not clear enough but let me know if you need some more info.

edit retag flag offensive close merge delete


I'm not sure I understand what you're trying to achieve. Have you (accidentally) removed your src folder and are now trying to recreate it using artefacts from devel?

I believe that'll be difficult, as devel contains the result of the build. For C++-based nodes, that means only their binaries will be in devel, no source code. For Python-based nodes, the sources will (typically) only be symlinked, meaning they would not be present in devel either.

gvdhoorn gravatar image gvdhoorn  ( 2022-03-12 04:37:30 -0600 )edit

Kind of but I am okay with losing the src/ directory since there is none. Consider when you do something like sudo apt install ros-noetic-<pkg-name> then the package will be installed in your ros path directly. It is the same but when I try to source the it does not recognize the pkgs inside there.

I am trying to install and use this I am running on ros melodic, but do not see any version specification on their installation guide. After installation, it creates /opt/xbot/ directory and it has sub directories include/, 'lib/', share/ and file, I tried editing and creating setup.bash along with the but it didn't worked. I am not so sure what to do next.

aarsh_t gravatar image aarsh_t  ( 2022-03-12 08:59:30 -0600 )edit

I'm still confused. Could you clarify what you're trying to do? Is there something wrong with the installation instructions of the package(s) you link? Are the regular installation instructions not working?

If you are running into problems following the regular instructions, please describe those problems, instead of asking a question about a solution you came up with. We should try to avoid solving an xy-problem.

gvdhoorn gravatar image gvdhoorn  ( 2022-03-13 03:03:23 -0600 )edit

Sorry for the delay. Finally I have opened issue on their github. I think the question formation was not clear here from my side. Apologies for that.

aarsh_t gravatar image aarsh_t  ( 2022-03-22 09:19:04 -0600 )edit