ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

Not able to install navigation and slam packages in noetic

asked 2022-01-28 01:32:42 -0600

SarveshV gravatar image

I tried using sudo apt-get install ros-noetic-navigation but I get a few lines 404 error stating not found IP and failed to fetch packages from packages.ros.org

Err:1 http://packages.ros.org/ros/ubuntu focal/main amd64 ros-noetic-amcl amd64 1.17.1-1focal.20210922.193203 404 Not Found [IP: 64.50.233.100 80] . . .

E: Failed to fetch http://packages.ros.org/ros/ubuntu/po... 404 Not Found [IP: 64.50.233.100 80]

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-01-28 20:10:31 -0600

Mike Scheutzow gravatar image

The internal list of apt packages is probably out of date. Try running sudo apt update to refresh the package list, then retry the apt-get command.

edit flag offensive delete link more

Comments

Thanks Mike,but sudo apt update didnt work.The issue rectified when I ran source.list and keys setup commands from noetic installation page.

SarveshV gravatar image SarveshV  ( 2022-01-31 01:59:27 -0600 )edit

Question Tools

2 followers

Stats

Asked: 2022-01-28 01:31:16 -0600

Seen: 372 times

Last updated: Jan 28 '22