Ask Your Question
0

Problems about Turtlebot Camera Network RViz

asked 2012-07-21 02:24:52 -0500

Yuri gravatar image

updated 2013-10-17 17:53:14 -0500

130s gravatar image

Hello, i was just that i'm working with ROS and Turtlebot. My configuration is: Workstation: Dell xps (i7 and 8Gb RAM) ubuntu 11.10(64bit, Wubi) Ros electric Netbook (on Turtlebot): Samsung N150 ubuntu 10.04 Ros electric Robot: Turtlebot Camera: Asus Xtion pro live

I encountered several problems:

1) If on netbook run turtlebot service i can not send commands by workstation while if i stop the service with sudo service turtlebot stop and launch roslaunch turtlebot_bringup minimal.launch or other on netbook the system works (eg the teleop by the workstation is ok). Why?

2)If i try to start the nodes of the camera on netbook (i try with openni.launch openni_node.launch kinect.launch) i can see the image on my netbook perfectly with commands as: rosrun image_view image_view image:=/camera/rgb/image_color(or mono) or in rviz but on the workstation the images arrive with very delay (about 45s) and after few seconds the network falls. I must reset the network board of the workstation because it no works with any network. The dashboard, when i launch the nodes of the camera on netbook, show this message:

[/openni_camera] Number devices connected: 1 INFO [/openni_camera] 1. device on bus 001:04 is a PrimeSense Device (600) from PrimeSense (1d27) with serial id '' INFO [/openni_camera] device_id is not set! Using first device. WARN [/openni_camera] Opened 'PrimeSense Device' on bus 1:4 with serial number '' INFO rgb_frame_id = 'camera_rgb_optical_frame' INFO depth_frame_id = 'camera_depth_optical_frame' INFO

but after is totally ok and if i launch rostopic hz /camera... on netbook i get:

avarage rate:21.802 min: 0.011s max: 1.410s std dev: 0.10654s window: 169

avarage rate:22.500 min: 0.011s max: 1.410s std dev: 0.09880s window: 197

about once for second instead on workstation i get:

average rate: 0.297 min: 3.369s max: 3.369s std dev: 0.00000s window: 2

no new messages

no new messages

average rate: 0.296 min: 3.369s max: 3.379s std dev: 0.00498s window: 3

no new messages

no new messages

average rate: 0.300 min: 3.265s max: 3.379s std dev: 0.05116s window: 4

no new messages

no new messages

average rate: 0.303 min: 3.189s max: 3.379s std dev: 0.07817s window: 5

no new messages

no new messages

no new messages

no new messages... Why?

I have tried to exchange the dell xps with the netbook and the images arrive with about 2s of delay (from workstation to netbook) and the visualization is better but the network still falls after few time. What is the problem? I wish i could see on my workstation what the camera on Turtlebot sees when the robot go. How could i do to get this? The network should be set well because the teleop, the rostopic pub(in any direction) and the ping work.

3) When the nodes of the camera are active, on netbook, on rviz(that it works only setting ... (more)

edit retag flag offensive close merge delete

Comments

What resolution is the camera?

allenh1 gravatar image allenh1  ( 2012-07-21 08:00:06 -0500 )edit

The resolution is 1280*1024 but today i have tried to change workstation (i have used a acer aspire 5920) and the network was slow (delay 2s, acceptable), but don't falls!! On my Dell i have try to change the setting in reconfigure_gui. i have decreased the quality but the network falls always.

Yuri gravatar image Yuri  ( 2012-07-24 03:58:39 -0500 )edit

I just tried again with acer and the delay is 40s, but the network doesn't fall.

Yuri gravatar image Yuri  ( 2012-07-24 04:08:51 -0500 )edit

rostopic bw /camera/rgb/image_color subscribed to [/camera/rgb/image_color] ^Caverage: 130.30KB/s mean: 921.66KB min: 921.66KB max: 921.66KB window: 3

Yuri gravatar image Yuri  ( 2012-07-24 04:16:48 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-07-22 06:25:20 -0500

Ryan gravatar image

1) I suggest running "sudo /usr/sbin/turtlebot-start" and checking out the errors. That's what "sudo service turtlebot start" actually runs.

2) What does running "rostopic bw /camera" say? You could try using the compressed image topic instead - use a republish node on your local machine to subscribe to the compressed topic and uncompress it on your local machine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-21 02:24:52 -0500

Seen: 954 times

Last updated: Jul 22 '12