ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosmake doesn't include custom msg header files

asked 2012-07-20 12:18:23 -0600

Mike Shomin gravatar image

updated 2012-07-22 08:04:30 -0600

Solved: see my answer below.

When I try to compile a package of mine on OSX electric, the c++ header files aren't found for custom messages. This did not happen before I tried to install fuerte. When I hit a roadblock, I realized it wasn't worth it and reverted to electric. I think I have everything back to normal, but this issue remains.

rospack depends-msgsrv [my_package]

yields all the right paths to the header files for core libraries, but not those which are defined in my own packages. I know my package path is fine, and running the same commands (both rospack and actual compilation) work fine on ubuntu 10.04 running electric. The result of the rospack command includes the paths to my packages with custom msgs. I'm not sure where to look next as far as debugging. Any suggestions?

edit retag flag offensive close merge delete


Did you make clean in all your packages after switching versions?

joq gravatar image joq  ( 2012-07-20 12:51:00 -0600 )edit

Yes, I did.

Mike Shomin gravatar image Mike Shomin  ( 2012-07-22 06:53:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2012-07-22 08:04:00 -0600

Mike Shomin gravatar image


There was a Makefile in the package generated from cmake (not the simple one that finds mk), so the "make"/"make clean" didn't do the right things as they were generated with the fuerte build system. After replacing them the with standard Makefile that finds mk, making clean, and then rebuilding (along with all the messages), it worked.

edit flag offensive delete link more


Hey Mike,

I have a similar problem. May you explain with more details what you did?


RaianSpinelli gravatar image RaianSpinelli  ( 2014-10-15 15:48:13 -0600 )edit

Question Tools

1 follower


Asked: 2012-07-20 12:18:23 -0600

Seen: 961 times

Last updated: Jul 22 '12