Ask Your Question
0

Roscd is not working on fuerte

asked 2012-07-17 19:20:35 -0500

SHPOWER gravatar image

updated 2014-01-28 17:13:03 -0500

ngrennan gravatar image

Hi All,

I am trying to use Roscd in Ubuntu terminal. In return I get "roscd: command not found". Help me please.

Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
4

answered 2012-07-17 22:01:32 -0500

Lorenz gravatar image

While @prince's answer surely will work, I guess the problem is that you don't source /opt/ros/fuerte/setup.bash, assuming you are using Fuerte. Are you maybe sourcing /opt/ros/fuerte/setup.sh? Make sure you've set up your environment correctly as described here.

edit flag offensive delete link more
1

answered 2012-07-17 20:25:59 -0500

prince gravatar image

You need to run following command

source ${ROS_ROOT}/tools/rosbash/rosbash

Please refer to following link http://ros.org/wiki/rosbash

www.ros.org/wiki has well managed dooumentation for most of the things. It is nice idea to read the documentation if you are new to it and search the forum.

edit flag offensive delete link more
1

answered 2012-07-17 23:18:42 -0500

SHPOWER gravatar image

I found out what my problem was... I did not configure my ros_package_path correctly.

edit flag offensive delete link more

Comments

1

Also, if you are using roscd, you need to configure your ros workspace.

allenh1 gravatar imageallenh1 ( 2012-07-18 03:53:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-17 19:20:35 -0500

Seen: 1,904 times

Last updated: Jul 17 '12