Ask Your Question
0

no device connected turtlebot kinect [closed]

asked 2012-07-16 23:44:48 -0600

MBN gravatar image

updated 2016-10-24 08:34:07 -0600

ngrennan gravatar image

Im trying to run kinect but it gives the massage no device connected ... im pretty sure that the power works well and there is no problem with that..can u please help me out?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-01-05 19:38:39

Comments

We'll need some more information in order to help you...

allenh1 gravatar imageallenh1 ( 2012-07-17 05:08:56 -0600 )edit
1

How are you trying to run the Kinect?

Ryan gravatar imageRyan ( 2012-07-17 09:51:08 -0600 )edit

every thing was fine until i tried to run rviz . when i run rviz a message came that its failed to load nodelet [openni_camera] so i thought maybe the drivers have not been installed so i did the instruction for openni_camera in ros website, i follow them all but at the stage that i wanted to start-

MBN gravatar imageMBN ( 2012-07-17 18:20:26 -0600 )edit

start kinect.launch it gives the msg no device connected

MBN gravatar imageMBN ( 2012-07-17 18:21:21 -0600 )edit

4 Answers

Sort by ยป oldest newest most voted
0

answered 2012-07-17 15:49:04 -0600

You should also check that you have a file at /etc/udev/rules.d/55-primesense-usb.rules

You may need to add the user running the launch file to the "video" group to get permissions on this device.

edit flag offensive delete link more
0

answered 2012-07-17 18:52:51 -0600

MBN gravatar image

doughbot01 : oic, maybe its a silly question, how to be member of video group?

edit flag offensive delete link more

Comments

You need to use the command "sudo adduser $USER video". However, if everything was fine I'm not sure if that was the problem. What do you mean by "everything was fine" before that... you had received kinect images before then?

dougbot01 gravatar imagedougbot01 ( 2012-07-17 19:54:42 -0600 )edit

no i haven't receive the image it was giving me the error unable to load nodelet [openni_camera]. but it didn't give the msg no device connected ,

MBN gravatar imageMBN ( 2012-07-17 20:01:23 -0600 )edit

btw i already became a member but still i get this msg : [INFO] [1342591333.817740897]: [/openni_camera] No devices connected.... waiting for devices to be connected

MBN gravatar imageMBN ( 2012-07-17 20:03:24 -0600 )edit

Ideas 1) Make sure you're on a USB2 port. I've heard USB3 doesn't work. 2) Verify Kinect lights are on or blinking, indicating power is ok. 3) Read here http://answers.ros.org/question/12107/kinect-no-devices-connected-on-openni_nodelaunch/

dougbot01 gravatar imagedougbot01 ( 2012-07-17 20:12:20 -0600 )edit

Also, did you buy a turtlebot pre-made, or you are building it yourself? I'm just curious about how you've wired up the 12V power ?

dougbot01 gravatar imagedougbot01 ( 2012-07-17 20:13:07 -0600 )edit

i bought it pre-made

MBN gravatar imageMBN ( 2012-07-17 20:36:55 -0600 )edit
0

answered 2012-07-17 07:14:41 -0600

PerkinsJames gravatar image

Read your /var/log/messages after you plug in the kinect. You may not have your kinect sensor drivers setup correctly.

edit flag offensive delete link more
0

answered 2012-07-17 20:21:34 -0600

MBN gravatar image

updated 2012-07-17 20:28:28 -0600

dougbot01: this is exactly what i get:

turtlebot@turtlebot-laptop:~$ lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 003 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 001 Device 016: ID 045e:02ae Microsoft Corp.

Bus 001 Device 015: ID 045e:02ad Microsoft Corp.

Bus 001 Device 012: ID 045e:02b0 Microsoft Corp.

Bus 001 Device 011: ID 0409:005a NEC Corp. HighSpeed Hub

Bus 001 Device 004: ID 13d3:5711 IMC Networks

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

turtlebot@turtlebot-laptop:~$ roslaunch turtlebot_bringup kinect.launch

... logging to /home/turtlebot/.ros/log/2cb0993e-d09c-11e1-ba91-94dbc938ebcd/roslaunch-turtlebot-laptop-13670.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://10.61.130.152:55575/

SUMMARY

PARAMETERS * /kinect_laser/max_height * /openni_camera/depth_rgb_rotation * /rosdistro * /openni_camera/image_mode * /openni_camera/image_time_offset * /openni_camera/projector_depth_baseline * /kinect_laser_narrow/output_frame_id * /openni_camera/depth_mode * /kinect_laser_narrow/max_height * /openni_camera/depth_frame_id * /openni_camera/depth_time_offset * /kinect_laser/output_frame_id * /rosversion * /openni_camera/depth_registration * /openni_camera/debayering * /openni_camera/depth_rgb_translation * /kinect_laser/min_height * /pointcloud_throttle/max_rate * /openni_camera/shift_offset * /kinect_laser_narrow/min_height * /openni_camera/rgb_frame_id

NODES / kinect_breaker_enabler (turtlebot_node/kinect_breaker_enabler.py) openni_manager (nodelet/nodelet) openni_camera (nodelet/nodelet) pointcloud_throttle (nodelet/nodelet) kinect_laser (nodelet/nodelet) kinect_laser_narrow (nodelet/nodelet)

ROS_MASTER_URI=http://10.61.130.152:11311

core service [/rosout] found process[kinect_breaker_enabler-1]: started with pid [13688] process[openni_manager-2]: started with pid [13692] process[openni_camera-3]: started with pid [13693] process[pointcloud_throttle-4]: started with pid [13694] process[kinect_laser-5]: started with pid [13701] process[kinect_laser_narrow-6]: started with pid [13707] [kinect_breaker_enabler-1] process has finished cleanly. log file: /home/turtlebot/.ros/log/2cb0993e-d09c-11e1-ba91-94dbc938ebcd/kinect_breaker_enabler-1*.log

edit flag offensive delete link more

Comments

Ok, I have a guess now. Actually my "turtlebot" I built with an ASUS Xtion so maybe I never thought of this. The key here I think is the kinect_breaker_enabler. Check this website on turtlebot tutorials regarding the dashboard http://www.ros.org/wiki/turtlebot_bringup/Tutorials/TurtleBot%20Bringup

dougbot01 gravatar imagedougbot01 ( 2012-07-17 20:27:26 -0600 )edit

You have to set the iRobot create to "full mode" to enable breaker 0, which will power the kinect. At least, I'm guessing this could be a problem, but the fact the process has exited is concerning

dougbot01 gravatar imagedougbot01 ( 2012-07-17 20:28:40 -0600 )edit

dashboard working fine all lights are green with also 0 breaker and the kinect cabel light also is green

MBN gravatar imageMBN ( 2012-07-17 20:30:07 -0600 )edit

after getting these msges which i showed u it start giving me the msg no device connected

MBN gravatar imageMBN ( 2012-07-17 20:31:13 -0600 )edit

Sorry, but it's almost midnight here and I have to go to bed. Although this is a silly one, I have to try since you have the exact same error. Good luck! http://answers.ros.org/question/34233/no-devices-connected-error-with-turtlebot/

dougbot01 gravatar imagedougbot01 ( 2012-07-17 20:51:08 -0600 )edit

its ok thank u :)

MBN gravatar imageMBN ( 2012-07-17 21:01:55 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2012-07-16 23:44:48 -0600

Seen: 1,801 times

Last updated: Jul 17 '12