Ask Your Question
0

Colcon merge fails

asked 2021-10-21 06:28:43 -0600

C:\dev\ros2_foxy>colcon build --merge-install Starting >>> ament_package Starting >>> ament_lint Starting >>> gtest_vendor Starting >>> fastcdr Starting >>> ament_cppcheck Starting >>> cyclonedds Starting >>> osrf_pycommon Starting >>> osrf_testing_tools_cpp Starting >>> google_benchmark_vendor Starting >>> urdfdom_headers Starting >>> ament_pycodestyle Finished <<< ament_lint [3.47s] Starting >>> ament_flake8 Finished <<< osrf_pycommon [3.58s] Finished <<< ament_cppcheck [3.73s] Finished <<< ament_package [3.88s] Finished <<< gtest_vendor [4.00s] Starting >>> ament_cmake_core Starting >>> gmock_vendor Finished <<< ament_pycodestyle [4.05s] Starting >>> ament_pyflakes --- stderr: fastcdr CMake Deprecation Warning at CMakeLists.txt:18 (cmake_minimum_required): Compatibility with CMake < 2.8.12 will be removed from a future version of CMake.

Update the VERSION argument <min> value or use a ...<max> suffix to tell CMake that the project does not need compatibility with older versions.


Finished <<< fastcdr [5.03s] Finished <<< google_benchmark_vendor [5.03s] Finished <<< urdfdom_headers [5.08s] Finished <<< ament_flake8 [2.78s] Starting >>> ament_pep257 Starting >>> ament_mypy Finished <<< ament_pyflakes [3.41s] Finished <<< gmock_vendor [4.44s] Finished <<< ament_cmake_core [4.66s] Starting >>> ament_cmake_libraries Starting >>> ament_cmake_export_libraries Starting >>> ament_cmake_python Starting >>> ament_cmake_include_directories Starting >>> ament_cmake_export_definitions Starting >>> ament_cmake_export_include_directories Starting >>> ament_cmake_export_link_flags Starting >>> ament_cmake_version Finished <<< osrf_testing_tools_cpp [9.08s] Starting >>> test_interface_files Finished <<< ament_pep257 [3.12s] Starting >>> ament_copyright Finished <<< ament_mypy [4.08s] Starting >>> test_osrf_testing_tools_cpp Finished <<< ament_cmake_include_directories [4.14s] Starting >>> ros_environment Finished <<< ament_cmake_version [4.31s] Finished <<< ament_cmake_libraries [4.75s] Finished <<< ament_cmake_export_link_flags [4.91s] Finished <<< ament_cmake_export_libraries [5.25s] Finished <<< ament_cmake_export_include_directories [5.36s] Finished <<< test_interface_files [5.22s] Starting >>> ament_cmake_export_dependencies Starting >>> ament_cmake_export_targets Starting >>> ament_cmake_export_interfaces Starting >>> ament_cmake_target_dependencies Finished <<< ament_copyright [5.33s] Finished <<< ament_cmake_python [6.36s] Finished <<< ament_cmake_export_definitions [6.55s] Starting >>> ament_cmake_test Starting >>> domain_coordinator Starting >>> ament_index_python Starting >>> ament_lint_cmake Starting >>> ament_xmllint Finished <<< test_osrf_testing_tools_cpp [9.39s] Starting >>> ament_cpplint Finished <<< cyclonedds [20.0s] Starting >>> ament_clang_format Finished <<< ament_cmake_export_targets [5.95s] Finished <<< ament_cmake_export_dependencies [6.22s] Starting >>> ament_clang_tidy Starting >>> ament_pclint Finished <<< ament_cmake_target_dependencies [6.45s] Finished <<< ament_cmake_export_interfaces [6.69s] Finished <<< ros_environment [8.48s] Finished <<< ament_lint_cmake [6.09s] Finished <<< domain_coordinator [6.27s] Finished <<< ament_xmllint [6.20s] Starting >>> rpyutils Starting >>> tracetools_trace Starting >>> tracetools_read Finished <<< ament_cmake_test [9.06s] Finished <<< ament_index_python [9.09s] Starting >>> ament_cmake Starting >>> ament_cmake_gtest Starting >>> ament_cmake_pytest Starting >>> ament_cmake_lint_cmake Starting >>> ament_lint_auto C:\Python310\lib\site-packages\setuptools\dist.py:717: UserWarning: Usage of dash-separated 'script-dir' will not be supported in future versions. Please use the underscore name 'script_dir' instead warnings.warn( C:\Python310\lib\site-packages\setuptools\dist.py:717: UserWarning: Usage of dash-separated 'install-scripts' will not be supported in future versions. Please use the underscore name 'install_scripts' instead warnings.warn( C:\Python310\lib\site-packages\setuptools\dist.py:717: UserWarning: Usage of dash-separated 'script-dir' will not be supported in future versions. Please use the underscore name 'script_dir' instead warnings.warn( C:\Python310\lib\site-packages\setuptools\dist.py:717: UserWarning: Usage of dash-separated 'install-scripts' will not be supported in ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-10-28 00:25:09 -0600

The build error clearly indicates that Qt5 could not be found. Please review this step in the installation instructions and ensure that Qt has been installed and configured correctly: https://docs.ros.org/en/rolling/Insta...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-10-21 06:28:43 -0600

Seen: 20 times

Last updated: Oct 28