Ask Your Question
2

Installation of Fuerte under Fedora 14

asked 2012-07-16 02:05:53 -0500

Flowers gravatar image

updated 2014-01-28 17:13:01 -0500

ngrennan gravatar image

Hey,

I followed the instructions and everything went fine until the cmake stuff. Fedora Installation Guide

cmake .. -DCMAKE_INSTALL_PREFIX=/opt/ros/fuerte -DSETUPTOOLS_DEB_LAYOUT=OFF -- +++ catkin -- Could NOT find PY_em (missing: PY_EM) CMake Error at catkin/cmake/empy.cmake:29 (message): Unable to find either executable 'empy' or Python module 'em'... try
installing package 'python-empy' Call Stack (most recent call first):
catkin/cmake/all.cmake:51 (include)
catkin/CMakeLists.txt:12 (include)

any ideas?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-16 03:55:33 -0500

joq gravatar image

It looks like you are missing the EmPy Python package. On Ubuntu that is installed as a Debian package dependency.

Maybe there is a corresponding Fedora 14 package. If so, I would use it.

Otherwise, try installing it with pip:

sudo pip install -U EmPy
edit flag offensive delete link more
0

answered 2012-07-24 02:39:57 -0500

Flowers gravatar image

Finally made it via: apt-get install python-empy

However, there is a new problem: Couldn't find log4cxx library

I already checked for the log4cxx package, which is installed, still cmake won't find it...do I have to change some system variable(most likely something like LIB_PATH?)?

thx

edit flag offensive delete link more

Comments

Rather than asking new questions in the form of an "answer", please open a new question for this problem. That way others will be able to find the solution, too.

joq gravatar image joq  ( 2012-07-24 03:18:35 -0500 )edit
0

answered 2012-08-07 18:59:39 -0500

hi,

I'm using fedora 17 -- I'm also at the point where it is asking for the log4cxx library as well and I was able to run: yum install log4cxx but I still get the same error.

would that be the same file or libraries of files? I'm not a programmer, just a tech and I'm doing this for a programmer so my knowledge is limited so any help would be greatly appreciated.

thanks

edit flag offensive delete link more
0

answered 2012-10-18 23:04:13 -0500

SidSid gravatar image

Hi Flowers, I am at the same point that you are in this post. libcxx is installed but I'm getting the "Couldn't find log4cxx library" message. Did you find a solution to this problem?

edit flag offensive delete link more

Comments

Not really sure, but I think it was something about renaming a libfile because it had the version in it's name like log4cxx-v-105

Flowers gravatar image Flowers  ( 2012-11-14 02:21:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-16 02:05:53 -0500

Seen: 835 times

Last updated: Oct 18 '12