ros-foxy-desktop : Depends: ros-foxy-pcl-conversions

asked 2021-10-07 13:46:21 -0500

c-mon gravatar image

Hi,

I am have just followed the installation procedure for ROS2 Foxy.

sudo apt install ros-foxy-desktop

This gives the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-foxy-desktop : Depends: ros-foxy-pcl-conversions but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have rerun all the commands but it still does not work. I am not sure how to debug this but in the mean time I'll build from source.

edit retag flag offensive close merge delete

Comments

Which OS?

Did you clean up the broken packages? Try sudo apt remove ros-foxy-desktop, and search for "Unable to correct problems, you have held broken packages" for advice on getting back to a good state.

The instructions at https://docs.ros.org/en/foxy/Installa... should work well.

clyde gravatar image clyde  ( 2021-10-07 18:16:56 -0500 )edit