No image display from depth camera Pepper.

asked 2021-09-17 09:06:12 -0500

DAC31415 gravatar image

updated 2021-09-24 04:40:58 -0500


I am having issues displaying the depth camera of the robot pepper on rviz, I have checked (echo) all the topics and none of them have data. Anyone else have encounter the same issue.

I'm using ros melodic and ubuntu 18.04.

Update: it appears that the module it's destroyed. Tried to get the points from the topic /pepper_robot/camera/depth_registered/points

as mentioned in

Also, if I uncomment the lines 197, 198 can't compile anymore. To enable the front camera, I have to run camera.launch

[INFO] [1632475357.031810]: subscribed to camera proxy, since this is the first camera Exception in thread Thread-1: Traceback (most recent call last):   File "/usr/lib/python2.7/", line 801, in __bootstrap_inner   File "/home/danalcruz/catkin_ws/src/naoqi_bridge/naoqi_sensors_py/src/naoqi_sensors/", line 249, in run
        self.reconfigure(self.config, 0)   File "/home/danalcruz/catkin_ws/src/naoqi_bridge/naoqi_sensors_py/src/naoqi_sensors/", line 154, in reconfigure
        new_config['frame_rate'])   File "/home/danalcruz/pynaoqi-python2.7-", line 194, in __call__
        return self.__wrapped__.method_missing(self.__method__,
    *args, **kwargs)   File "/home/danalcruz/pynaoqi-python2.7-", line 264, in method_missing
        raise e RuntimeError:   ALVideoDevice::subscribeCamera  module destroyed
edit retag flag offensive close merge delete


I think the problem can be with your publish depth camera code or camera node. Did you check that you are able to publish is correct?

You can share more details so that can helps us to provide you a better solution.

Ranjit Kathiriya gravatar image Ranjit Kathiriya  ( 2021-09-17 09:23:45 -0500 )edit

Thank you. I will check that as soon as I have access to the robot. That might be one issue cause I have a lot of topics created but haven't realized which one is which one.

DAC31415 gravatar image DAC31415  ( 2021-09-20 12:24:21 -0500 )edit

Apparently, when I tried to subscribe to the depth camera the module gets destroyed. I update the question

DAC31415 gravatar image DAC31415  ( 2021-09-24 04:36:04 -0500 )edit