Ask Your Question
0

"ROS_DISTRO was set to 'noetic' before" while sourcing ROS 2 setup.bash

asked 2021-09-07 21:26:14 -0600

sibi055 gravatar image

updated 2021-09-08 02:26:26 -0600

gvdhoorn gravatar image

Is it correct or i should do any configurations? please tell me thanks in advance

future_engineer@grayhat:~$ source /opt/ros/galactic/setup.bash
ROS_DISTRO was set to 'noetic' before. Please make sure that the environment does not mix paths from different distributions.
future_engineer@grayhat:~$ env |grep ROS
ROS_VERSION=2
ROS_PYTHON_VERSION=3
ROS_PACKAGE_PATH=/opt/ros/noetic/share
ROSLISP_PACKAGE_DIRECTORIES=
ROS_ETC_DIR=/opt/ros/noetic/etc/ros
ROS_MASTER_URI=http://localhost:11311
ROS_LOCALHOST_ONLY=0
ROS_ROOT=/opt/ros/noetic/share/ros
ROS_DISTRO=galactic
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-09-08 04:26:05 -0600

Ranjit Kathiriya gravatar image

updated 2021-09-08 04:28:20 -0600

You also need to unset your noetic path: unset ROS_PACKAGE_PATH_FOR_NOETIC #q62589

Then try, I think it will work.

edit flag offensive delete link more

Comments

2

It's possible (likely perhaps even) the OP has a source /opt/ros/noetic/setup.bash in his/her .bashrc, which "auto-sources" in each terminal.

gvdhoorn gravatar image gvdhoorn  ( 2021-09-08 04:33:57 -0600 )edit

Hey @gvdhoorn,

It's possible (likely perhaps even) the OP

I am sorry, Can you please! tell me the meaning of the OP?

Thanks!

Ranjit Kathiriya gravatar image Ranjit Kathiriya  ( 2021-09-08 08:05:14 -0600 )edit

Original Poster

gvdhoorn gravatar image gvdhoorn  ( 2021-09-08 08:06:59 -0600 )edit

Thanks once again.

Ranjit Kathiriya gravatar image Ranjit Kathiriya  ( 2021-09-08 08:07:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2021-09-07 21:26:14 -0600

Seen: 58 times

Last updated: Sep 08 '21