Moveit2 build _____ mesh_operations.cpp:41:10: fatal error: resource_retriever/retriever.hpp: No such file or directory

asked 2021-08-25 07:35:51 -0500

slon gravatar image

Hello, i am following these instructions on how to build moveit2 on ubuntu 20.04 with ros2 and rviz:

http://moveit2_tutorials.picknik.ai/d...

When i get to step

cd ~/ws_moveit2

colcon build --event-handlers desktop_notification- status- --cmake-args -DCMAKE_BUILD_TYPE=Release

I get following output

Starting >>> warehouse_ros
Starting >>> geometric_shapes
Finished <<< warehouse_ros [1.43s]
Starting >>> rviz_visual_tools
Finished <<< rviz_visual_tools [2.40s]
Starting >>> warehouse_ros_mongo
--- stderr: geometric_shapes
/home/ubuntu/ws_moveit2/src/geometric_shapes/src/mesh_operations.cpp:41:10: fatal error: resource_retriever/retriever.hpp: No such file or directory
   41 | #include <resource_retriever/retriever.hpp>
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/geometric_shapes.dir/build.make:102: CMakeFiles/geometric_shapes.dir/src/mesh_operations.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [CMakeFiles/Makefile2:137: CMakeFiles/geometric_shapes.dir/all] Error 2
make: *** [Makefile:141: all] Error 2
---
Failed   <<< geometric_shapes [10.7s, exited with code 2]
Aborted  <<< warehouse_ros_mongo [40.9s]

Summary: 2 packages finished [45.0s]
  1 package failed: geometric_shapes
  1 package aborted: warehouse_ros_mongo
  1 package had stderr output: geometric_shapes
  1 package not processed

in the folder /home/ubuntu/ws_moveit2/src/geometric_shapes/src/ there is a file mesh_operations.cpp

ROS_VERSION=2 ROS_PYTHON_VERSION=3 ROS_LOCALHOST_ONLY=0 ROS_DISTRO=foxy

Thanks for help

edit retag flag offensive close merge delete

Comments

Can you go in moveit directory and type git branch? Let me know what is the output inside the moveit directory

kak13 gravatar image kak13  ( 2021-08-25 15:06:57 -0500 )edit

I ran the command and below is the output:

ubuntu@ubun2004:~$ cd ~/ws_moveit2

ubuntu@ubun2004:~/ws_moveit2$ git branch

fatal: not a git repository (or any parent up to mount point /)

Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

ubuntu@ubun2004:~/ws_moveit2$ git init

Initialized empty Git repository in /home/ubuntu/ws_moveit2/.git/

i found "git init" should help so i tried it but the result was still the same, i.e. the same error as in OP

slon gravatar image slon  ( 2021-08-30 05:02:08 -0500 )edit

I'm not sure. The reason why I asked for git branch because I did it another day and I had a different distro from the github which caused me a lot of issues. I couldn't see what did you download so idk now. sorry!

kak13 gravatar image kak13  ( 2021-08-30 08:26:43 -0500 )edit