ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Uncrustify vendor fails to compile in ROS2_Galactic

asked 2021-08-12 01:37:09 -0500

Dickson gravatar image

Bug report

Required Info:

  • Operating System:
    • Windows 10
  • Installation type:
    • source
  • Version or commit hash:
    • ROS2 Galactic
  • DDS implementation:
    • RTI-Connext
  • Client library :
    • Uncrustify_vendor

Steps to reproduce issue

-colcon build --merge-install --packages-select uncrustify_vendor --event-handlers console_cohesion+ console_direct+

It seems to me that the CMakeLists of uncrustify is having issues. Is the issue on ros_crystal in this thread the same error as i am currently experiencing in ros galactic? If it is, how do i solve this issue?

Performing patch step for 'uncrustify-45b836cff040594994d364ad6fd3f04adc890a26' CUSTOMBUILD : error : patch failed: CMakeLists.txt:440 [C:\dev\ros2_galactic\build\uncrustify_vendor\uncrustify-45b836cff040594994d364ad6fd3f04adc890a26.vcxproj] CUSTOMBUILD : error : CMakeLists.txt: patch does not apply [C:\dev\ros2_galactic\build\uncrustify_vendor\uncrustify-45b836cff040594994d364ad6fd3f04adc890a26.vcxproj]

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-08-12 02:03:50 -0500

Dickson gravatar image

Solved the CMake error by using an older version ROS2 Foxy implementation.

Copy the contents of that github page into


and it should solve the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2021-08-12 01:37:09 -0500

Seen: 321 times

Last updated: Aug 12 '21