ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

conda install ROS missing libraries for RViz

asked 2021-08-11 22:38:03 -0500

xparr45 gravatar image

updated 2021-08-12 11:34:21 -0500


I am new to ROS and Linux systems and wanted to try using Anaconda to debug and analyze ROS data. To get the ROS packages to be recognized by Anaconda, I executed this command

conda install -c conda-forge -c robostack ros-noetic-desktop

This seemed to have overwritten some paths where my original ROS-noetic was installed but I didn't mind at first. Everything on Anaconda worked fine with being able to recognize ROS packages.

I tried spinning up a session of ROS and RVIZ on terminal to view some data then things started breaking...

[ERROR] [1628738525.051051644]: InternalErrorException: Could not load dynamic library /home/pdk2/anaconda3/lib/OGRE/RenderSystem_GL. System Error: /home/pdk2/anaconda3/lib/OGRE/ cannot open shared object file: No such file or directory in DynLib::load at /home/conda/feedstock_root/build_artifacts/ogre_1573024423694/work/OgreMain/src/OgreDynLib.cpp (line 111) does not exist so I am stumped as to what I should do and if any other normal ROS packages are broken.

I appreciate any help you can offer!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-08-12 12:56:40 -0500

xparr45 gravatar image

Fixed it temporarily by not having conda initialize on start by removing the changes the conda installation made in the ,bashrc file. Not ideal but works for now.

edit flag offensive delete link more

Question Tools



Asked: 2021-08-11 22:38:03 -0500

Seen: 262 times

Last updated: Aug 12 '21