Ask Your Question
0

I am getting error while loading shared libraries: libboost_system.so.1.65.1

asked 2021-07-19 19:16:42 -0600

mkanchan gravatar image

I am getting below error when trying to ros and webots. I tired to run an existing example:

$roslaunch webots_ros keyboard_teleop.launch

Webots gets launched and shows below error: /usr/local/webots/projects/default/controllers/ros/ros: error while loading shared libraries: libboost_system.so.1.65.1: cannot open shared object file: No such file or directory WARNING: 'ros' controller exited with status: 127.

I am using Ubuntu20.04, ROS noetic

I tried searching for this lib, I have libboost_system.so.1.71... not sure why it is looking for older version,

Appreciate any help

edit retag flag offensive close merge delete

Comments

Try to link your libraries following this steps : https://stackoverflow.com/a/4581396/4...

Ranjit Kathiriya gravatar image Ranjit Kathiriya  ( 2021-07-21 04:36:18 -0600 )edit

I do not have this library any where on my ubuntu 20.04. It has newer version 1.71 not 1.65. How can I add this. Thanks for your response

mkanchan gravatar image mkanchan  ( 2021-07-21 14:38:27 -0600 )edit

Do you get the same error if you install Webots from the tarball? https://github.com/cyberbotics/webots...

Make sure to remove the Webots apt package first, sudo apt remove webots

lukicdarkoo gravatar image lukicdarkoo  ( 2021-07-22 01:56:37 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2021-08-23 07:42:59 -0600

To increase visibility I posting my comment as an answer (we received quite some complaints).

As of Webots R2021c (or R2022a), ROS Noetic will work with the Debian package (but ROS Melodic will not).

Under-the-hood: Cyberbotics uses a CI based on Ubuntu 18.04 to build the Debian package. Since the ros controller comes as a precompiled binary it is linked against Ubuntu 18.04/Melodic libraries (some of which don't exist on Ubuntu 20.04/Noetic). Cyberbotics have upgraded the CI to use Ubuntu 20.04 (see cyberbotics/webots#3507) for Webots R2021c (or R2022a), so in the future Noetic users will not have any more issues with the Debian packages.

edit flag offensive delete link more
0

answered 2021-07-21 15:31:21 -0600

Mike Scheutzow gravatar image

updated 2021-07-21 15:37:09 -0600

The standard libboost library in ubuntu 20 is 1.65.1, and the ros packages from apt are built using that exact version. It is unwise of you to install a different version of the libboost library on your computer. It will make it very difficult to use many of the binary ros packages available from apt and other places, as you have just discovered.

You could re-compile everything from source code, and it would work, but it is a lot of effort.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-07-19 19:16:42 -0600

Seen: 436 times

Last updated: Aug 23 '21