Ask Your Question
0

rplidar_node on ros2 / Autoware drops message for ‚Unknown‘ reason

asked 2021-07-11 01:39:59 -0500

heavy02011 gravatar image

updated 2021-07-12 05:48:16 -0500

I‘m using Autoware and the rplidar_node showing correct messages (ros2 topic echo scan) but it fails to get them shown on rviz2 with this error message

[INFO] [1625892725.336256970] [rviz]: Message Filter dropping message: frame 'laser_frame' at time 1625892723.515 for reason 'Unknown'

When I use ros melodic everything works fine.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2021-07-12 11:24:26 -0500

Josh Whitley gravatar image

This is likely because the global frame that you have set in rviz2 is not laser_frame and you haven't defined a transform between laser_frame (the frame in which the laser scans are being published) and the global frame that you are using in rviz2. In order to visualize the scan data while using a global frame other than the sensor's frame, you must define and publish (either with a URDF file and robot_state_publisher or tf2_static_transform_publisher) the frame transform between the laser's frame and at least one other frame in your transform tree (usually base_link). Hope this helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-07-10 06:23:20 -0500

Seen: 128 times

Last updated: Jul 12 '21