Ask Your Question
0

Unable to sync with device - Arduino Nano rosserial

asked 2021-06-27 20:47:56 -0500

Hello.

I am trying to use rosserial to communicate between a Jetson Nano 2GB and Arduino Nano.

Here is my error: [ERROR] [1624844028.297385]: Unable to sync with device; possible link problem or link software version mismatch such as hydro rosserial_python with groovy Arduino

I have already tried the suggestions in this forum post such as changing the baud rate on both ends, different cable, etc. I am only subscribing to one topic from the Arduino Nano.

I am new to ROS, so any help is appreciated. Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-07-01 21:19:01 -0500

I have been able to resolve the issue. The issue is due to the Arduino Nano and the limited 'bandwidth'. Bandwith may not be the right word, but the Nano is not able to handle it. An Arduino Mega will resolve the issue and I have tried the Teensy 4.0, and with a modified ros_lib library, it seems to have solved the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-06-27 20:47:31 -0500

Seen: 47 times

Last updated: Jul 01