ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Rosdep install not locating definitions [rostime] [catkin] [rospy]

asked 2021-06-22 20:11:50 -0600

Daggrosh gravatar image

updated 2021-06-24 02:06:33 -0600

gvdhoorn gravatar image

I'm following this tutorial:

When I run rosdep install -i --from-path src --rosdistro foxy -y, I get the following output:

ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
rospy_tutorials: Cannot locate rosdep definition for [rospy]
roscpp_tutorials: Cannot locate rosdep definition for [rostime]
ros_tutorials: Cannot locate rosdep definition for [catkin]
turtlesim: Cannot locate rosdep definition for [rostime]

My understanding is that rosdep looks for package names and keys. If I apt search rostime, for example, I get librostime0d as output. I have tried modifying package.xml with the search results.

I have tried looking through rosdep's base.yaml as this question suggests: but my rosdep isn't located at ros/foxy/rosdep, it's located inside /usr/lib/python3/dist-packages/rosdep2 and that folder doesn't contain a base.yaml file.

When searching for the packages using dpkg -S I am able to find them.

Where can I modify rosdep's definitions if not ros/foxy/rosdep/base.yaml or how can I otherwise instruct rosdep to locate the definitions?

edit retag flag offensive close merge delete



The question is somewhat confusing.

You tagged it ros2 and foxy, mention the ROS 2 Foxy installation tutorial, but the rosdep output mentions ROS 1 packages exclusively. None of those packages are used with ROS 2 Foxy.

Did something go wrong setting up your workspace?

I would refrain from editing all sorts of files until you've cleared that up.

gvdhoorn gravatar image gvdhoorn  ( 2021-06-23 03:09:57 -0600 )edit

I assume they cloned the wrong branch of The command to clone the branch for Foxy (as written in the tutorial) is: git clone -b foxy-devel

christophebedard gravatar image christophebedard  ( 2021-06-23 19:01:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-06-23 20:06:48 -0600

Daggrosh gravatar image

Thank you both. I live in China and for some reason cannot git clone from terminal effectively, with or without a vpn. SO I went to the github page and downloaded the zip. But I didn't switch the branch to foxy and instead downloaded the noetic zip.

edit flag offensive delete link more


Please just post an answer if you've solved your own problem. Do not edit titles to include words like solved or answered.

gvdhoorn gravatar image gvdhoorn  ( 2021-06-24 02:07:08 -0600 )edit

Noted. Thank you.

Daggrosh gravatar image Daggrosh  ( 2021-06-24 02:08:51 -0600 )edit

Question Tools

1 follower


Asked: 2021-06-22 20:11:50 -0600

Seen: 1,340 times

Last updated: Jun 24 '21