Can someone please help me to identify as to where I went wrong in installing ROS melodic.. [closed]

asked 2021-06-16 11:01:55 -0500

Azeem gravatar image

updated 2022-05-23 09:02:19 -0500

lucasw gravatar image

Hi, I am a newbie trying to use ROS. I somehow managed to dual boot my system by using an external hard disk as my storage for my Ubuntu OS and files associated with it. I followed the instructions provided in the official ROS melodic website which ( Once, I completed, I tried to use roscore command in terminal and it threw me an error as shown below. I am lost, please guide me. I am using Ubuntu version 18.04.

azeem@azeem-s-edith:~$ roscore

Command 'roscore' not found, but can be installed with:

sudo apt install python-roslaunch

azeem@azeem-s-edith:~$ sudo apt install python-roslaunch
[sudo] password for azeem: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-roslaunch : Depends: python-roslib but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
edit retag flag offensive reopen merge delete

Closed for the following reason too subjective or argumentative by Andromeda
close date 2022-05-24 08:32:54.972584


Did you source /opt/ros/melodic/setup.bash ?

kscottz gravatar image kscottz  ( 2021-06-17 20:54:57 -0500 )edit

Thank you for your response and Yes I did @kscottz. Actually, I have figured what was wrong and solved it. The reason I had these errors is because I had some broken packages. Once I removed them all and did a clean, fresh install everything works like a charm.

Azeem gravatar image Azeem  ( 2021-06-22 06:43:23 -0500 )edit