cartographer error Lookup would require extrapolation into the past. Requested time 1619368236.404072 but the earliest data is at time 1619368254.143571, when looking up transform from frame [odom] to frame [imu_link]

asked 2021-04-25 11:43:49 -0600

rnandez22 gravatar image

updated 2021-04-25 21:59:36 -0600

jayess gravatar image

I am using a TurtleBot3 with ROS2 Foxy in Ubuntu 20.04. When I do the bringup : [ros2 launch turtlebot3_bringup robot.launch.py] I get:

opt/ros/foxy/share/turtlebot3_bringup/launch/robot.launch.py:76: UserWarning: The parameter 'node_executable' is deprecated, use 'executable' instead
  Node(
urdf_file_name : turtlebot3_burger.urdf
/opt/ros/foxy/share/turtlebot3_bringup/launch/turtlebot3_state_publisher.launch.py:47: UserWarning: The parameter 'node_executable' is deprecated, use 'executable' instead
  Node(
/opt/ros/foxy/share/turtlebot3_bringup/launch/turtlebot3_state_publisher.launch.py:47: UserWarning: The parameter 'node_name' is deprecated, use 'name' instead  Node(
/opt/ros/foxy/share/hls_lfcd_lds_driver/launch/hlds_laser.launch.py:46: UserWarning: The parameter 'node_executable' is deprecated, use 'executable' instead
  Node(
/opt/ros/foxy/share/hls_lfcd_lds_driver/launch/hlds_laser.launch.py:46: UserWarning: The parameter 'node_name' is deprecated, use 'name' instead
  Node(
[INFO] [robot_state_publisher-1]: process started with pid [2034]
[INFO] [hlds_laser_publisher-2]: process started with pid [2036]
[INFO] [turtlebot3_ros-3]: process started with pid [2038]
[hlds_laser_publisher-2] [INFO] [1619367658.007489776] [hlds_laser_publisher]: Init hlds_laser_publisher Node Main
[hlds_laser_publisher-2] [INFO] [1619367658.008081438] [hlds_laser_publisher]: port : /dev/ttyUSB0 frame_id : base_scan
[turtlebot3_ros-3] [INFO] [1619367658.032319061] [turtlebot3_node]: Init TurtleBot3 Node Main
[turtlebot3_ros-3] [INFO] [1619367658.036130073] [turtlebot3_node]: Init DynamixelSDKWrapper
[turtlebot3_ros-3] [INFO] [1619367658.042015913] [DynamixelSDKWrapper]: Succeeded to open the port(/dev/ttyACM0)!
[turtlebot3_ros-3] [INFO] [1619367658.047752431] [DynamixelSDKWrapper]: Succeeded to change the baudrate!
[robot_state_publisher-1] [WARN] [1619367658.053738426] [robot_state_publisher]: No robot_description parameter, but command-line argument available.  Assuming argument is name of URDF file.  This backwards compatibility fallback will be removed in the future.

Nevertheless, the problem starts when I want to use cartographer [ ros2 launch turtlebot3_cartographer cartographer.launch.py]:

[cartographer_node-1] [WARN] [1619368247.210829877] [cartographer_ros]: W0425 18:30:47.000000 43568 tf_bridge.cc:67] Lookup would require extrapolation into the past.  Requested time 1619368236.404072 but the earliest data is at time 1619368238.043610, when looking up transform from frame [odom] to frame [imu_link]
[cartographer_node-1] [WARN] [1619368247.216076739] [cartographer_ros]: W0425 18:30:47.000000 43568 tf_bridge.cc:67] Lookup would require extrapolation into the past.  Requested time 1619368236.404072 but the earliest data is at time 1619368238.043610, when looking up transform from frame [odom] to frame [imu_link]
[rviz2]: Message Filter dropping message: frame 'base_scan' at time 1619368253,252 for reason 'Unknown'

I have been following the Robotis e-manual and did not configure anything else than what's there. I tried syncronizing the time and starting again the setup from zero but is not working

[view_frames]: Result:tf2_msgs.srv.FrameGraph_Response(frame_yaml="base_link: \n  parent: 'base_footprint'\n  broadcaster: 'default_authority'\n  rate: 10000.000\n  most_recent_transform: 0.000000\n  oldest_transform: 0.000000\n  buffer_length: 0.000\nbase_footprint: \n  parent: 'odom'\n  broadcaster: 'default_authority'\n  rate: 20.206\n  most_recent_transform: 1619368817.092736\n  oldest_transform: 1619368812.242739\n  buffer_length: 4.850\ncaster_back_link: \n  parent: 'base_link'\n  broadcaster: 'default_authority'\n  rate: 10000.000\n  most_recent_transform: 0.000000\n  oldest_transform: 0.000000\n  buffer_length: 0.000\nimu_link: \n  parent: 'base_link'\n  broadcaster: 'default_authority'\n  rate: 10000.000\n  most_recent_transform: 0.000000\n  oldest_transform: 0.000000\n  buffer_length: 0.000\nbase_scan: \n  parent: 'base_link'\n  broadcaster: 'default_authority'\n  rate: 10000.000\n  most_recent_transform: 0.000000\n ...
(more)
edit retag flag offensive close merge delete