Ask Your Question
0

rqt error: Could not import "pyqt" bindings of qt_gui_cpp library - so C++ plugins will not be available

asked 2021-04-19 04:06:50 -0500

jensebr gravatar image

Hi all,

First post!

I am having some issues with running rqt packages on my PC. I had no problems when running this on another PC with Ubuntu 18.04 and ROS Melodic. So, I assume there are some issues with support for newer versions?

On this PC, I have Ubuntu 20.04 and ROS Noetic. When I try to rosrun any rqt package, I get the error:

Could not import "pyqt" bindings of qt_gui_cpp library - so C++ plugins will not be available: Traceback (most recent call last): File "/opt/ros/noetic/lib/python3/dist-packages/qt_gui_cpp/cpp_binding_helper.py", line 43, in <module> from . import libqt_gui_cpp_sip ImportError: /home/username/.local/lib/python3.8/site-packages/PyQt5/Qt/lib/libQt5Core.so.5: version `Qt_5.12' not found (required by /opt/ros/noetic/lib/python3/dist-packages/qt_gui_cpp/libqt_gui_cpp_sip.so)

However, the rqt packages still usually work (e.g. rqt_reconfigure). One package that does not work (the window does not pop up) is rqt_multiplot - and this is a package that I need. When trying to rosrun rqt_multiplot, I get the same error as above, but also this:

qt_gui_main() found no plugin matching "MultiplotPlugin" try passing the option "--force-discover"

However, I can find rqt_multiplot in my lib folder. I have also tried to run "rqt --force-discover", but it does not show up.

I did encounter some problems when installing rqt_multiplot, which may be the source of the problem (https://github.com/ANYbotics/rqt_mult...). More specifically, I had issues with installing the dependencies. When running "sudo apt-get install libqwt-dev" for installing qwt, I got the error:

E: Package 'libqwt-dev' has no installation candidate

When I run "qmake --version", I get: Using Qt version 5.12.8 in /usr/lib/x86_64-linux-gnu

I have the newest version of PyQt5 (5.11.2) installed via pip3, but I have tried many older versions as well without luck.

Note that there is a mismatch between the PyQt5 version and the Qt version..

I am a noob at this. I have tried to reinstall ROS as well, but it did not help. Does anyone have any ideas on how I could fix this issue? Any help is greatly appreciated. Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-04-26 06:45:26 -0500

phil333 gravatar image

Same issue here, found this solution that works for me: Just run the following line:

 pip3 uninstall PyQt5-sip PyQt5

(details under the following link: https://stackoverflow.com/questions/6... )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-04-19 04:06:50 -0500

Seen: 1,140 times

Last updated: Apr 26 '21