No messages published from raspberry are being recieved by master computer

asked 2021-04-15 15:14:49 -0500

mahta gravatar image

updated 2021-04-16 05:10:26 -0500

Hi, I've been recently trying to comunicate raspberry pi 3b on my two wheeled robot, with my own computer which the master is running on. But I got an issue with recieving data or msgs on the computer(which rostopic echo /cmd_vel doesn't respond to any commands I publish on my rpi) although it works vice versa; I have no problems with commanding rpi and controling wheels, with teleop_twist_keyboard package. I've tested changing my rpi to raspberry4, changing my modem to a more powerful one, and also tested with many other packages and differents topics and msgs. (Rostopic list is complete,shows both nodes running on both machines, Rqt graph on the computer is just fine, it shows all the topics running on both devices, subscribers and publishers are also connected as expected. It just doesn't recieve any msgs from them) I also tried changing master ip to rpi and running roscore on rpi, used ntpdate to minimize time difference(sudo ntpdate ntpdate.ubuntu.com) and none of them worked. For ROS networking configs I followed this tutorial and only changed the master ip to my computer's ip:

Link: (https://www.hackster.io/dmitrywat/rgb...)

Here is my two last lines of ~/.bashrc file on rpi: export ROS_IP=192.168.43.71 export ROS_MASTER_URI=https://192.168.43.251:11311 and simply like that for my own computer and it's ip.

P.s: long ago I once managed to get kinect data from rpi to computer, and visualize it on rviz, but after a while that I installed more pkgs and added some files to run my project, this issue happend and I've got no idea why.

Both devices are ubuntu 18.04 and running on ROS melodic.

edit retag flag offensive close merge delete

Comments

Did you fix the problem ?

Os7 gravatar image Os7  ( 2022-05-27 12:16:16 -0500 )edit

Yes I did. It was the firewall. Make sure both your machines have been set proper ufw rules or completely turned off. Good luck

mahta gravatar image mahta  ( 2022-05-27 16:38:31 -0500 )edit