I dont see GUI of turtlebot when i run launch command in terminal

asked 2021-03-30 01:15:49 -0500

I am new to ROS. I am using virtual machine ubuntu server and i am accessing through my mac terminal. I have installed ROS melodic and turtlebot3. I have no problem running roscore but when i run the below command i can it getting started but i dont see any GUI where i see and more turtle. Ideally, there should be another window opened with GUI but nothing happens.

ranjanj1@ubuntu:~/catkin_ws$ roslaunch src/turtlebot3/turtlebot3_example/launch/turtlebot3_illumination.launch

... logging to /home/ranjanj1/.ros/log/979f6ed8-911c-11eb-b6ff-000d3a9e9da4/roslaunch-ubuntu-15343.log Checking log directory for disk usage. This may take a while. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:39947/

SUMMARY

PARAMETERS * /rosdistro: melodic * /rosversion: 1.14.10

NODES / turtlebot3_illumination (turtlebot3_example/turtlebot3_illumination)

auto-starting new master process[master]: started with pid [15353] ROS_MASTER_URI=http://localhost:11311

setting /run_id to 979f6ed8-911c-11eb-b6ff-000d3a9e9da4 process[rosout-1]: started with pid [15364] started core service [/rosout] process[turtlebot3_illumination-2]: started with pid [15367]

Ubuntu version:

ranjanj1@ubuntu:~/catkin_ws$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.3 LTS Release: 18.04 Codename: bionicimage description

edit retag flag offensive close merge delete