ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

/opt/ros/noetic/setup.bash : No such file or directory found

asked 2021-03-28 10:27:39 -0500

Tatsat gravatar image

I have installed ROS Noetic on my Virtualbox with UBUNTU 20.04. Every time I run this command: source /opt/ros/noetic/setup.bash. I get the above mentioned error. I have tried removing this line from .bashrc file..(was not there...I added it and then removed difference). The problem is I cannot find setup.bash file anywhere. Also I reinstalled by making new folder and opening it terminal. Still no difference. This setup file does not seems to be downloaded or the directory is completely unknown,

edit retag flag offensive close merge delete



If that file can't be found, I'd make sure you've correctly installed ROS.

What's the output of dpkg -l | grep ros-noetic?

gvdhoorn gravatar image gvdhoorn  ( 2021-03-29 01:06:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-04-08 08:02:42 -0500

Tatsat gravatar image

Hello, thank you for the reply. Yes you are correct. It was not installed correctly. I ran: sudo apt install ros-noetic-desktop-full .... again and the problem got solved.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2021-03-28 10:27:39 -0500

Seen: 3,536 times

Last updated: Mar 28 '21