Ask Your Question
0

cannot ping [/my_turtle]: unknown node [closed]

asked 2012-06-28 02:56:20 -0500

richkappler gravatar image

updated 2012-07-03 12:56:32 -0500

mjcarroll gravatar image

working the tutorials, all went well until

[code] rosnode ping my_turtle [/code]

got back

[code] rosnode: node is [/my_turtle] cannot ping [/my_turtle]: unknown node [/code]

Verified path, network setup, etc all went exactly as described until ping. First time working with ROS, what should I look at next?

edit: went back through tutorial, but before changing name of turtlesim to my_turtle, pinged turtlesim and it worked fine.

regards, Richard

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by richkappler
close date 2014-01-07 09:12:55

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-06-28 03:02:47 -0500

dornhege gravatar image

Judging from your edit I'm guessing you are pinging the wrong name. View the running nodes with rosnode list.

edit flag offensive delete link more
0

answered 2012-06-28 03:14:05 -0500

richkappler gravatar image

updated 2012-06-28 03:14:30 -0500

Did that, got

/rosout

/my_turtle

regards, Richard

edit flag offensive delete link more

Comments

So, when you do rosnode ping/info /my_turtle, you get the error message?

dornhege gravatar image dornhege  ( 2012-06-28 03:32:50 -0500 )edit

no, the command in the tutorial is rosnode ping my_turtle. This works with the original turtle call, but not with the renamed turtle.

richkappler gravatar image richkappler  ( 2012-06-28 03:34:33 -0500 )edit

Hi,richkappler, what is the meaning of the last comments? Thanks. Why works original turtle not renamed turtle? How to solve this problem?

jql gravatar image jql  ( 2018-10-10 20:07:43 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2012-06-28 02:56:20 -0500

Seen: 980 times

Last updated: Jun 28 '12