ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Was Gazebo started with GazeboRosFactory? error when launching urdf file

asked 2021-03-18 15:57:21 -0500

pablo.arandarod gravatar image

I'm trying to spawn my robot in Gazebo by using the following command:

ros2 run gazebo_ros -entity myentity -x 0 -y 0 -z 0 -file WorkSpace/src/urdf_screencast/urdf/urdf_screencast.urdf

In this command, I substituted WorkSpace with the path to the ROS workspace. When I execute this command, after waiting for the service /spawn_entity, it appears to have the error that gives the name to this post.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-03-24 12:07:43 -0500

clyde gravatar image

Make sure you load the libgazebo_ros libraries in Gazebo, e.g., gazebo -s -s

edit flag offensive delete link more


This worked for me

_Chris gravatar image _Chris  ( 2021-12-03 07:41:06 -0500 )edit

Also worked for me.

I worked with the docker image osrf/ros:galactic-desktop, have got this error. Then executed this command in the second terminal (after source, and spawned the robot successfully.


Seffo gravatar image Seffo  ( 2023-01-06 06:37:48 -0500 )edit

Question Tools

1 follower


Asked: 2021-03-18 15:57:21 -0500

Seen: 5,350 times

Last updated: Mar 24 '21