Error while building catkin package

asked 2021-03-16 14:12:30 -0500

nishkarshsharma gravatar image

updated 2021-03-16 19:56:17 -0500

tryan gravatar image


File "/usr/local/bin/catkin", line 9, in <module>
  load_entry_point('catkin-tools==0.5.0', 'console_scripts', 'catkin')()
File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 542, in load_entry_point
  return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2569, in load_entry_point
  return ep.load()
File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2229, in load
  return self.resolve()
File "/usr/lib/python2.7/dist-packages/pkg_resources/", line 2235, in resolve
  module = __import__(self.module_name, fromlist=['__name__'], level=0)
File "/usr/local/lib/python2.7/dist-packages/catkin_tools/commands/", line 200
edit retag flag offensive close merge delete


What package are you trying to build? How are you building it? and what is your complete error stack?

Akhil Kurup gravatar image Akhil Kurup  ( 2021-03-16 21:31:57 -0500 )edit

I was shifting from melodic to kinetic to implement a certain package and hence tried to build an empty src in catkin workspace but was faced with the error shown above while using catkin build. Tried reinstalling catkin but to no avail. Please Help!

nishkarshsharma gravatar image nishkarshsharma  ( 2021-03-19 09:12:56 -0500 )edit