ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

UserWarning: ERROR: No flags found

asked 2021-03-14 08:07:19 -0600

Ataraxy gravatar image

updated 2021-11-09 10:43:43 -0600

clyde gravatar image

When i run ros2 doctor to check my setup, there is an error UserWarning: ERROR: No flags foundandFailed modules: network. Does someone know why this situation happened and how to solve it? I would be appreciated for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2021-03-24 12:29:52 -0600

clyde gravatar image

updated 2021-11-09 10:43:49 -0600

I found this issue interesting:

The fix is to make sure that ifconfig is installed. You can install it by running this command: apt-get update && apt-get install net-tools

edit flag offensive delete link more



I have the same problem running ros2doctor on Windows 10. How can I solve it?

BUONLEO gravatar image BUONLEO  ( 2021-11-09 04:31:09 -0600 )edit

What is the exact error?

clyde gravatar image clyde  ( 2021-11-09 10:44:39 -0600 )edit

I have the same problem as @BUONLEO: " UserWarning: ERROR: No flags found" on Windows, how did you solved it ?

Louis.G gravatar image Louis.G  ( 2022-06-28 18:56:35 -0600 )edit

I suggest you start a new question for Windows.

clyde gravatar image clyde  ( 2022-07-01 07:37:09 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools



Asked: 2021-03-14 08:07:19 -0600

Seen: 332 times

Last updated: Nov 09 '21