Unable to rostopic echo from another computer. No messages received and simulated time is active. Is /clock being published?

asked 2021-03-13 00:56:04 -0600

etorobot gravatar image

updated 2021-03-13 02:03:39 -0600

On the MASTER, however, rostopic echo works fine.

rostopic list works fine on both machines but rostopic echo from the other computer gives an error.

:~$ rostopic echo /joint_states 
WARNING: no messages received and simulated time is active.
Is /clock being published?

according to rostopic list yes, it is, however:

:~$ rostopic echo /clock
WARNING: no messages received and simulated time is active.
Is /clock being published?

The simulator (on MASTER) isn't paused because rostopic echo works on that computer.

Any help appreciated

edit retag flag offensive close merge delete

Comments

1

Did you set the ROS network variables? http://wiki.ros.org/ROS/Tutorials/Mul...

GeorgNo gravatar image GeorgNo  ( 2021-03-15 11:43:30 -0600 )edit

@GeorgNo Yes, using the same ROS_MASTER_URI on both and their indidivual IP addresses as ROS_IP. No hostnames.

It still doesn't work unless i export ROS_IP in terminal before roslaunch.

etorobot gravatar image etorobot  ( 2021-03-15 14:00:29 -0600 )edit
1

IMHO you should set ROS_IP and ROS_MASTER_URI and ROS_HOSTNAME in your ~/.bashrc

GeorgNo gravatar image GeorgNo  ( 2021-03-25 06:24:08 -0600 )edit

@GeorgNo although i've done that (on both computers), i still get "is /clock being published?" unless i export ROS_IP in terminal before rostopic echo

etorobot gravatar image etorobot  ( 2021-04-14 22:57:05 -0600 )edit