Can´t install Autoware.Auto

asked 2021-03-10 14:44:33 -0500

rzr900ipl gravatar image

I tried to install autoware (dashing) auto on a virtual machine with the ubuntu 18.04 operating system. I ran the following commands: ********* Installing the docker ************

//Uninstalling old versions

$ sudo apt-get remove docker docker-engine containerd runc

// Creating docker engine installation repository

$ sudo apt-get update

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    gnupg-agent \

$ curl -fsSL | sudo apt-key add -
$ sudo apt-key fingerprint 0EBFCD88
$ sudo add-apt-repository \
   "deb [arch=amd64] \
   $(lsb_release -cs) \
$ sudo apt-get update
$ sudo apt-get install docker-ce docker-ce-cli
$ sudo docker run hello-world
$ sudo groupadd docker
$ sudo usermod -aG docker $USER


$ docker run hello-world

************ NVIDIA Docker ***********

$ sudo apt-get install linux-headers-$(uname -r)
$ distribution=$(. /etc/os-release;echo $ID$VERSION_ID | sed -e 's/\.//g')
$ wget$distribution/x86_64/cuda-$
$ sudo mv cuda-$ /etc/apt/preferences.d/cuda-repository-pin-600
$ sudo apt-key adv --fetch-keys$distribution/x86_64/
$ echo "deb$distribution/x86_64 /" | sudo tee /etc/apt/sources.list.d/cuda.list
$ sudo apt-get update
$ sudo apt-get -y install cuda-drivers
$ sudo reboot
$ distribution=$(. /etc/os-release;echo $ID$VERSION_ID) \
   && curl -s -L | sudo apt-key add - \
   && curl -s -L$distribution/nvidia-docker.list | sudo tee /etc/apt/sources.list.d/nvidia-docker.list
$ sudo apt-get update
$ sudo apt-get install -y nvidia-docker2
$ sudo systemctl restart docker
$ sudo docker run --rm --gpus all nvidia/cuda:11.0-base nvidia-smi

************ ADE Installation ***********

$ cd ${HOME}
$ mkdir adehome
$ cd adehome
$ wget
$ mv ade+x86_64 ade
$ chmod +x ade
$ sudo mv ade /usr/local/bin
$ which ade
$ sudo ade update-cli

//Update to 4.2.0

$ touch .adehome
$ git clone --recurse-submodules
$ cd AutowareAuto/
$  ade --rc .aderc-amd64-dashing  start --update --enter

********* Installation AutowareAuto ***********

ade$ exit
$ nano .aderc

//take off export ADE_DISABLE_NVIDIA_DOCKER=true, change the foxy to dashing

ade start -f
ade enter
ade$ cd AutowareAuto/
ade$ vcs import <$ROS_DISTRO.repos
ade$ colcon build --cmake-args -DCMAKE_BUILD_TYPE="Debug"

[Processing: had_map_utils]e] [had_map_utils:build 33% - 8min 51.4s] --- stderr: had_map_utils
c++: internal compiler error: Killed (program cc1plus) Please submit a full bug report, with preprocessed source if appropriate. See <file: usr="" share="" doc="" gcc-7="" readme.bugs=""> for instructions. make[2]: * [CMakeFiles/had_map_utils.dir/src/had_map_computation.cpp.o] Error 4 make[1]: * [CMakeFiles/had_map_utils.dir/all] Error 2

make: * [all] Error 2

Failed <<< had_map_utils [8min 59s, exited with code 2]

Summary: 6 packages finished [11min 38s] 1 package failed: had_map_utils 2 packages had stderr output: autoware_auto_common had_map_utils 80 packages not processed

I also had a error when I did the installation of the nvidia docker (one the least command), but I think it happened because the virtual machine does not have access to the GPU. Thanks for the trouble!

edit retag flag offensive close merge delete


I am getting the same error when I do the install on xubuntu 20.04 with foxy, thanks.

rzr900ipl gravatar image rzr900ipl  ( 2021-03-17 19:09:15 -0500 )edit

When I've seen this error in the past, it has been caused by the compiler running out of memory. How much memory have you allocated to the VM?

Additionally, we deprecated support for Dashing after the 1.0.0 release so we can't help much with problems on master unless you're using Foxy.

Josh Whitley gravatar image Josh Whitley  ( 2021-03-19 10:53:32 -0500 )edit

I allocated 44.36 GB of storage and 2048 MB of memory to VM. But I tried to do the install with foxy and the error was the same.

rzr900ipl gravatar image rzr900ipl  ( 2021-03-19 13:48:46 -0500 )edit

2GB is definitely too small. Allocate at least 4GB and try again.

Josh Whitley gravatar image Josh Whitley  ( 2021-03-20 06:58:17 -0500 )edit

ok, thank you for the help

rzr900ipl gravatar image rzr900ipl  ( 2021-03-20 08:31:05 -0500 )edit

I am do it what you said and it solve that problem but it did not do the complete colcon build. It gave error no package kalman filter:

/opt/ros/foxy/src/gtest_vendor/include/gtest/gtest.h:1495: undefined reference to `autoware::prediction::GenericState<float, autoware::prediction::variable::x,="" autoware::prediction::variable::y="">::kSize' collect2: error: ld returned 1 exit status make[2]: * [CMakeFiles/kalman_filter_gtest.dir/build.make:118: kalman_filter_gtest] Error 1 make[1]: * [CMakeFiles/Makefile2:103: CMakeFiles/kalman_filter_gtest.dir/all] Error 2

make: * [Makefile:141: all] Error 2

Failed <<< kalman_filter [25.8s, exited with code 2]

Can you help me again?

rzr900ipl gravatar image rzr900ipl  ( 2021-03-24 04:17:53 -0500 )edit

This is a different error from before and is probably a bug I introduced. Let me see why this is happening. If you feel blocked, just roll back 2 commits to a23ba919569d9b98e12e648fbfbee9e3f94731b9 and it will work there.

niosus gravatar image niosus  ( 2021-03-24 04:59:18 -0500 )edit

Just an update, the fix is already in review and will soon be released.

niosus gravatar image niosus  ( 2021-03-24 05:36:24 -0500 )edit