How to stop catkin_make_isolated ruining file paths?

asked 2021-02-01 11:50:01 -0600

Py gravatar image

updated 2021-02-02 10:30:08 -0600

I have installed cartographer on noetic according to the instructions here. This has been done alongside a working ROS package within the catkin_ws workspace, which worked great before installing cartographer.

The problem I am now having is that when I execute the initial ROS package (that uses the new cartographer package) some of my files are not found, e.g. GUI related for a web server node.

I suspect this is because cartographer has an isolated workspace whereas my ROS package doesn't. There seems to be some mismatch here that I don't fully understand. All I want to do is have my package find all the files it needs whilst being able to use cartographer at the same time.

Any ideas where I'm going wrong?

EDIT: I've just done a test using rosrun my_package web_server.sh and this serves the web GUI fine, however when I run roslaunch my_package all_nodes.launch, which includes the cartographer nodes, the GUI .html and .js files cannot be found.

edit retag flag offensive close merge delete