rviz: won't start, symbol lookup error

asked 2021-01-03 03:22:20 -0500

Godbless gravatar image

updated 2021-01-03 04:24:34 -0500

gvdhoorn gravatar image

Hi I'm using Ubuntu 18.04 and ros melodic. I'm a rookie in Linux and have been trapped for a long time. The error message is

yukun@yukun-xx:~$ rviz
[ INFO] [1609665391.478169493]: rviz version 1.13.15
[ INFO] [1609665391.478212214]: compiled against Qt version 5.9.5
[ INFO] [1609665391.478221917]: compiled against OGRE version 1.9.0 (Ghadamon)
[ INFO] [1609665391.483758677]: Forcing OpenGl version 0.
[ INFO] [1609665391.633321470]: Stereo is NOT SUPPORTED
[ INFO] [1609665391.633407262]: OpenGl version: 3,1 (GLSL 1,4).
rviz: symbol lookup error: /opt/ros/melodic/lib/libtf.so: undefined symbol: _ZN7tf2_ros17TransformListenerC1ERN3tf210BufferCoreERKN3ros10NodeHandleEb

Really appreciate your help!!

edit retag flag offensive close merge delete

Comments

ros-visualization/rviz#1575 seems related.

Something for you to check: do you have any outstanding updates for ROS packages?

You cannot update individual packages (or at least: it's not something I would recommend until you get a bit more experience).

if you have any ros-melodic-* packages waiting to be updated, please install them.

gvdhoorn gravatar image gvdhoorn  ( 2021-01-03 04:22:07 -0500 )edit

Seems like some part of the rviz core hasn't been installed properly. Can you try to apt install ros-melodic-desktop-full and see if that helps? If not, I am afraid you might have to uninstall ros completely and re-install it.

Akhil Kurup gravatar image Akhil Kurup  ( 2021-01-04 00:00:52 -0500 )edit

I'm getting the same error for rviz version 1.13.16 and the same specs otherwise. I had rviz running smoothly last year. But since the second last update it is throwing me that error.

JoSch gravatar image JoSch  ( 2021-03-23 10:35:15 -0500 )edit

I got the same error, which I can start rviz successfully in the morning but failed in the afternoon....

vincent_yangyang gravatar image vincent_yangyang  ( 2021-03-31 20:18:40 -0500 )edit