Rosbridge TCP server is no longer starting

asked 2020-12-22 17:10:45 -0600

corwinjs gravatar image

updated 2020-12-23 16:01:36 -0600

For the past year or so I have been using the following command to start up a rosbridge on my computer:

roslaunch rosbridge_server rosbridge_tcp.launch bson_only_mode:=True

Up until recently I would see the confirmation "Rosbridge TCP Server started on port 9090" and it worked as expected. Now when I run that same command I get the message "trying to start rosbridge TCP server.." printed repeatedly every second or two until I ctrl+c out.

Does anyone know what I can do to get my rosbridge working again? I'm using ROS melodic and ros-melodic-rosbridge-server on Ubuntu 18.04 4.15.0-128-generic.

edit: I solved the problem that I was seeing. The issue was that there was another process that was still using port 9090 on my machine. In fact, I suspect it was the remnants of a previous rosbridge process that I had going when my computer crashed for an unrelated reason a while back. To fix the issue, I used the lsof command to find which process was using that port and then killed it.

$ sudo lsof -i TCP:9090 | grep LISTEN
  python2 23156 corwinjs   13u  IPv4 37621397      0t0  TCP *:9090 (LISTEN)
$ kill -9 23156

Rosbridge was able to start successfully after that!

edit retag flag offensive close merge delete

Comments

Why did you delete your question?

If you've figured out why this was happening, then please post an answer to help others who may run into the same problem.

gvdhoorn gravatar image gvdhoorn  ( 2020-12-23 13:50:45 -0600 )edit

Please post your last edit as an answer and accept your own answer.

gvdhoorn gravatar image gvdhoorn  ( 2020-12-24 02:30:10 -0600 )edit