Ask Your Question
0

Rtab not mapping properly

asked 2020-12-19 15:36:32 -0500

Vish gravatar image

Hello Everyone, I am using the Leo rover with a zed2 camera in gazebo for mapping using rtabmap-ros. I have got the mapping part of rtabmap to work but while mapping the objects are being mapped multiple times around creating overlapping. Also, while I run Rviz, the pointcloud of objects are not stationary and slightly moves around with the robot. So in the map, multiple copies of all the objects around, which also overlaps with each other are created

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-24 14:02:34 -0500

matlabbe gravatar image

If there are dynamic objects, you would have to use the octomap with ray tracing enabled (Grid/RayTracing to true) and subscribe to /rtabmap/octomap_occupied_space (PointCloud2) or the published octomap (/rtabmap/octomap_full).

Do you need a 3D map or a 2D occupancy grid could be enough? It is because 3D ray tracing is computensively expensive. If 2D map is ok, set Grid/2D to true and subscribe to /rtabmap/grid_map.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-19 15:36:32 -0500

Seen: 133 times

Last updated: Dec 24 '20