Ask Your Question
0

Real UR5 robot does not stop immediately upon receiving moveit stop command

asked 2020-12-17 11:23:50 -0500

prajval10 gravatar image

updated 2020-12-17 11:25:57 -0500

Setup:

  • ROS Melodic
  • Ubuntu 18.04
  • UR5 robot
  • UR software v3.8
  • URcaps version 1.0.2
  • Universal_Robots_ROS_Driver version used: branch master/commit

Issue

With planning cartesian trajectory with moveit as explained here, the robot does not stop immediately upon sending the stop() command but stops after 1 second approximately. On the controller side, the output shows path trajectory planning preempted, so it works as expected. We require the stop to happen almost instantaneously in order not to topple or destroy our manipulated object. We have tried also to set the speed scaling slider on the teach pendant to various values between 0-100%, but no effect. We have also tried changing the joint velicity limits in the joint_limit.yaml file in the respective moveit_config package.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2020-12-17 11:56:12 -0500

gvdhoorn gravatar image
edit flag offensive delete link more

Comments

As provided here https://github.com/UniversalRobots/Un..., setting stop_trajectory_duration to 0 in ur*_controllers.yaml fixes the issue.

prajval10 gravatar image prajval10  ( 2021-01-13 02:56:57 -0500 )edit

Thanks! that fixes the issue

prajval10 gravatar image prajval10  ( 2021-01-13 02:57:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-12-17 11:23:50 -0500

Seen: 99 times

Last updated: Jan 13