Ask Your Question
1

libpcan header files not found, where are they?

asked 2012-06-18 23:26:06 -0500

sjdowling gravatar image

updated 2014-01-28 17:12:43 -0500

ngrennan gravatar image

I need to compile some C++ with a libpcan.h include. According to the wiki libpcan is contained within cob-extern As I am using Ubuntu Precise I installed the ros-fuerte-cob-extern package. However it seems this does not include the required headers.

I then tried installing from the git repo but I get the following error when running the make file:

[rosbuild] Downloading https://code.ros.org/svn/release/download/thirdparty/peak-linux-driver-6.24.tar.gz to build/peak-linux-driver-6.24.tar.gz...Traceback (most recent call last): ... File "/opt/ros/fuerte/share/ros/core/rosbuild/bin/download_checkmd5.py", line 28, in main urllib.urlretrieve(uri, dest) ... IOError: [Errno socket error] [Errno 1] _ssl.c:504: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol make: *** [build/peak-linux-driver-6.24/unpacked] Error 1

Edit The SSL error seems to be to do with me being behind a proxy. I hosted the tarball locally and changed the url and that worked.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-06-19 20:08:51 -0500

weisshardt gravatar image

libpcan is downloading a tarball from code.ros.org. Are you sure you have internet access and code.ros.org is available from your location?

I just did a fresh checkout and successfull build on ubuntu 10.04, 11.10 and 12.04 for electric and fuerte.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-18 23:26:06 -0500

Seen: 1,009 times

Last updated: Jun 20 '12