Navigation Problems [closed]

asked 2012-06-15 08:52:16 -0500

allenh1 gravatar image

updated 2012-06-19 09:48:55 -0500

I am navigating with a pioneer-3dx robot. I have built a map (sort of) and can navigate through some of it. What would cause the robot to stop on its path? The map is incomplete because the robot stopped during its run. Could this be a communication error? Could it be related to the 256MB of RAM present on the robot or the 512 MHz processor? Any ideas are of use here. The robot currently has WiFi communication through its USB port attached to a "death spike" of an antenna. I know the communication works, for I am able to ssh onto the robot. I tried running roscore, rosbag, and the teleop on the robot with a screen command (to keep it running if ssh is lost), and it still stopped in motion.

Thanks in advance,

-Hunter A


Here is my p2os_dashboard.log file from the other day when I last ran it:

[rospy.client][INFO] 2012-06-15 12:31:03,216: init_node, name[/p2os_dashboard_25063_1339781463162], pid[25063]
[xmlrpc][INFO] 2012-06-15 12:31:03,217: XML-RPC server binding to 0.0.0.0
[xmlrpc][INFO] 2012-06-15 12:31:03,217: Started XML-RPC server [http://129.59.89.109:57674/]
[rospy.init][INFO] 2012-06-15 12:31:03,217: ROS Slave URI: [http://129.59.89.109:57674/]
[rospy.impl.masterslave][INFO] 2012-06-15 12:31:03,217: _ready: http://129.59.89.109:57674/
[xmlrpc][INFO] 2012-06-15 12:31:03,218: xml rpc node: starting XML-RPC server
[rospy.registration][INFO] 2012-06-15 12:31:03,218: Registering with master node http://10.20.67.73:11311
[rospy.registration][INFO] 2012-06-15 12:31:03,219: Registering publisher topic [/cmd_motor_state] type [p2os_driver/MotorState] with master
[rospy.registration][INFO] 2012-06-15 12:31:03,234: registering subscriber topic [/battery_state] type [p2os_driver/BatteryState] with master
[rospy.registration][INFO] 2012-06-15 12:31:03,258: registering subscriber topic [/motor_state] type [p2os_driver/MotorState] with master
[rospy.init][INFO] 2012-06-15 12:31:03,318: registered with master
[rospy.rosout][INFO] 2012-06-15 12:31:03,318: initializing /rosout core topic
[rospy.rosout][INFO] 2012-06-15 12:31:03,332: connected to core topic /rosout
[rospy.simtime][INFO] 2012-06-15 12:31:03,349: /use_sim_time is not set, will not subscribe to simulated time [/clock] topic
[rospy.internal][INFO] 2012-06-15 12:31:03,478: topic[/cmd_motor_state] adding connection to [/p2os], count 0
[rospy.internal][INFO] 2012-06-15 12:31:03,583: topic[/rosout] adding connection to [/rosout], count 0
[rospy.core][INFO] 2012-06-15 12:33:03,716: signal_shutdown [signal-2]
[rospy.internal][INFO] 2012-06-15 12:33:03,747: topic[/cmd_motor_state] removing connection to /p2os
[rospy.internal][INFO] 2012-06-15 12:33:03,748: topic[/rosout] removing connection to /rosout
[rospy.impl.masterslave][INFO] 2012-06-15 12:33:03,748: signal-2
[rospy.core][INFO] 2012-06-15 12:33:04,286: signal_shutdown [atexit]

Update: The robot is now stopping at a different location. I have tried two different sizes of antenna and it stops in the same place. What could be causing this issue?


The terminal outputs information too often to post it all. Here ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-03-22 13:37:20.676800

Comments

1

Do you get any output from the navigation stack either in the launch terminal or in the log files? (I assume you are also launching navigation in a screen session or running it on a separate PC).

Eric Perko gravatar imageEric Perko ( 2012-06-15 12:33:02 -0500 )edit

I am running the navigation on a separate pc. The pioneer simply cannot handle the navigation stack on its own computer. Would you please specify the log file you need to help me?

allenh1 gravatar imageallenh1 ( 2012-06-19 06:11:34 -0500 )edit

The best output would probably be from the terminal you launch from if you have output=screen or your move_base log file (I don't remember exactly where move_base rosconsole output gets logged to... I usually just had it also go to screen and checked the terminal when I used move_base frequently).

Eric Perko gravatar imageEric Perko ( 2012-06-19 08:33:13 -0500 )edit

Are you synchronizing the clocks on the robot and the separate PC, e.g. using chrony?

Eric Perko gravatar imageEric Perko ( 2012-06-19 15:40:40 -0500 )edit