How to set a static port to roslaunch?

asked 2020-11-20 08:15:10 -0500

wiyogo gravatar image

Since I'm working in a network with a firewall configuration, my admin has to release the port 11311 in order to connect to the robot ROS master. However, starting RViz from my PC, the gridmap and other topic data cannot be retrieved and shown on my RViz. I've checked on the robot board and cann see the gridmap and other topics. Thus, it is probably due to the firewall so that my RViz on my PC cannot visualize the gridmap.

I can see that the roslaunch starts with random port number. How can I set this port to be static, so that my admin can release this port in my network?


edit retag flag offensive close merge delete


See the answer to #q43913 - you are going to need a vpn.

lucasw gravatar image lucasw  ( 2020-11-20 16:41:27 -0500 )edit