Ask Your Question
0

autoware_rviz_plugins/BoundingBoxArray failed to load on ade foxy

asked 2020-11-07 06:32:33 -0600

runtao gravatar image

updated 2020-11-08 10:54:11 -0600

I am trying to run object detection demo of AutowareClass on ade foxy environment. If I run the following command, rviz2 started correctly, but the vehicle mesh was not imported correctly and the lidar points were not displayed correctly.

runtao@ade:~$ rviz2 -d /opt/AutowareAuto/share/autoware_auto_examples/rviz2/autoware_perception_stack.rviz QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-runtao' [INFO] [1604751402.293935945] [rviz2]: Stereo is NOT SUPPORTED [INFO] [1604751402.294147922] [rviz2]: OpenGl version: 4.6 (GLSL 4.6) [INFO] [1604751402.328090400] [rviz2]: Stereo is NOT SUPPORTED [ERROR] [1604751483.305751195] [rviz2]: PluginlibFactory: The plugin for class 'autoware_rviz_plugins/BoundingBoxArray' failed to load. Error: According to the loaded plugin descriptions the class autoware_rviz_plugins/BoundingBoxArray with base class type rviz_common::Display does not exist. Declared types are rviz_default_plugins/Axes rviz_default_plugins/Camera rviz_default_plugins/FluidPressure rviz_default_plugins/Grid rviz_default_plugins/GridCells rviz_default_plugins/Illuminance rviz_default_plugins/Image rviz_default_plugins/InteractiveMarkers rviz_default_plugins/LaserScan rviz_default_plugins/Map rviz_default_plugins/Marker rviz_default_plugins/MarkerArray rviz_default_plugins/Odometry rviz_default_plugins/Path rviz_default_plugins/PointCloud rviz_default_plugins/PointCloud2 rviz_default_plugins/PointStamped rviz_default_plugins/Polygon rviz_default_plugins/Pose rviz_default_plugins/PoseArray rviz_default_plugins/PoseWithCovariance rviz_default_plugins/Range rviz_default_plugins/RelativeHumidity rviz_default_plugins/RobotModel rviz_default_plugins/TF rviz_default_plugins/Temperature rviz_default_plugins/Wrench

Also, If I source /opt/AutowareAuto/setup.bash, it returns bash: /opt/AutowareAuto/setup.bash: No such file or directory, because there's no AutowareAuto repository under /opt on ade.

If I run this demo on default ade dashing environmnt, it works properly, so I beliveve there's something missing in foxy environment. Any idea how to solve this?


Added: the output of displaying lidar points:

runtao@ade:~$ source AutowareAuto/install/setup.bash; ros2 run velodyne_node velodyne_cloud_node_exe --model vlp16 __ns:=/lidar_front __params:=/opt/AutowareAuto/share/velodyne_node/param/vlp16_test.param.yaml [WARN] [1604853903.473366050] [rcl]: Found remap rule '__ns:=/lidar_front'. This syntax is deprecated. Use '--ros-args --remap __ns:=/lidar_front' instead. expected [string] got [not set]

edit retag flag offensive close merge delete

Comments

Hello, @runtao! Thanks for using Autoware! Unfortunately, ROS Foxy support is still experimental and the environment is not complete. The ade image is available and the source code will compile but many tests still fail. For this reason, the pre-built binary volume that is attached to /opt/AutowareAuto in the Dashing environment is not yet available in Foxy.

You have listed several problems here and the above explains the issue with the No such file or directory as well as the vehicle mesh (the URDF file requires a hard-coded path to the mesh file which currently points to the one normally installed to /opt/AutowareAuto/share). However, this does not explain why the lidar points are not being displayed. Can you please provide the output of the commands ros2 node list and ros2 topic list -t?

Josh Whitley gravatar image Josh Whitley  ( 2020-11-08 06:52:57 -0600 )edit

Hi @Josh Whitley, thanks for reply! Sorry forgot to add the output of displaying lidar points, I have just added it above. Since I cannot source /opt/AutowareAuto, I just source the overlay, but the velodyne_node still cannot get started.

Anyway, it seems like the foxy enivronment is not ready yet for such a demo as well as lgsvl, right? Do you have a time schedule on it? Btw, very appreciated for the improvement to foxy!

runtao gravatar image runtao  ( 2020-11-08 11:05:43 -0600 )edit

@runtao Yes, you are correct - this is an issue that has not yet been corrected for the Foxy environment. Unfortunately, I do not have a good timeline yet because Foxy support is only experimental until we begin working on our next development cycle (probably sometime around February). We are happy to accept fixes in merge requests! Since this problem is a direct conflict between Dashing and Foxy APIs, I recommend creating a copy of the launch file and adding the Foxy fixes. We need to maintain Dashing compatibility until our current development cycle is over.

Josh Whitley gravatar image Josh Whitley  ( 2020-11-09 17:44:33 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-02-07 14:21:17 -0600

RevatiNaik gravatar image

Hi, I am facing the same problem. I see this post was written almost three months back. Any updates on Foxy?

edit flag offensive delete link more

Comments

Foxy is now fully supported as of the 1.0.0 release last month. If you pull the latest AutowareAuto, you shoul dnot get these errors anymore.

Josh Whitley gravatar image Josh Whitley  ( 2021-03-05 15:19:26 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-11-07 06:32:33 -0600

Seen: 522 times

Last updated: Nov 08 '20