Robot prefix with Moveit2 & UR

asked 2021-06-08 04:08:17 -0600

definitive gravatar image

updated 2021-06-08 04:10:40 -0600

I need to initialize multiple planning groups with different names. Let's suppose a name "first_ur_manipulator", due to "ur_manipulator" as a default name. I changed required prefix in both launch files 1 2

        description="Prefix of the joint names, useful for \
    multi-robot setup. If changed than also joint names in the controllers' configuration \
    have to be updated.",

Then, in both controllers files 3 4 a prefix "first_" has been added to any single joint name. Moreover, in one launch file 2 within robot_description_content and robot_description_semantic_content I tried to change name from ur to several combinations, like ur3, first, first_ur, first_ur3. In general I tried any combination of steps mentioned above, for the instance changing prefix and remaining default joint names and so on. Result always was the same - in RVIZ panel interactive marker just disappear. I could notice that planning group name is changed to first_ur_manipulator (previously it was ur_manipulator) but still i can't interact with robot. So I checked where occur fixed name of ur_manipulator within package 6 and I changed ur_manipulator to first_ur_manipulator 7 8 but still it doesn't work.

How to change planning group name properly?

edit retag flag offensive close merge delete