Ask Your Question
0

Rosbag doesn't record cmd_vel on remote master

asked 2012-06-12 11:01:36 -0500

PKG gravatar image

updated 2012-06-12 11:21:33 -0500

I'm running Electric on Natty and have the following peculiar issue.

When I run rosbag -a on the above host, the bag output records cmd_vel. However, when I collect rosbag output after setting ROS_MASTER_URI to a different host (which runs diamondback on Lucid), I don't get cmd_vel recorded. Even

shell> rosbag record cmd_vel -a

fails to record cmd_vel in such a case, although all other topics are logged. Note that cmd_vel is being published always. What could be the problem?

Updated after Lorenzo's answer rostopic echo /cmd_vel gives the right output in such a case.

edit retag flag offensive close merge delete

Comments

Probably not the cause, but mixing Electric and Diamondback in a single ROS graph is a bad idea and not supported.

joq gravatar image joq  ( 2012-06-12 11:54:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-12 11:13:26 -0500

Lorenz gravatar image

updated 2012-06-12 11:23:50 -0500

This looks like a network problem to me. To prove, check if rostopic echo /cmd_vel also doesn't work. Have a look at this page for more information on debugging network issues.

Edit: Also try rosbag record cmd_vel instead of rosbag record -a to make sure that it hasn't something to do with the -a flag.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-12 11:01:36 -0500

Seen: 241 times

Last updated: Jun 12 '12