ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosserial install with fuerte?

asked 2012-06-10 16:02:35 -0600

punching gravatar image

Been trying to install rosserial with fuerte. Following the instructions here. BTW, someone needs to add a sudo to the first command. Took me about 10 minutes to figure that out.

when I run rosmake rosserial_arduino I get this:

mkdir: cannot create directory `build': Permission denied

I tried chmod'ing the rosserial_arduino folder to 777 to see if that would fix it and it didn't. Any ideas.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-06-10 20:08:48 -0600

kshitij gravatar image

updated 2012-06-12 00:34:04 -0600

You don't need to build rosserial_arduino.

Just copy the ros_lib folder from /rosserial/rosserial_arduino/libraries into your Arduino 'sketchbook' folder (or alternatively the /arduino/examples folder).

After you've done that, the example sketches will appear at File>sketchbook>ros_lib OR File>Examples>ros_lib on the Arduino IDE.

You can select any one of the example/tutorial sketches and compile/upload them to your board. (Follow the corresponding Tutorial from the wiki.)

P.S. Make sure you've made the following changes: in ros_lib edit ArduinoHardware.h: replace #include "WProgram.h" with #include "Arduino.h"

edit flag offensive delete link more

Question Tools


Asked: 2012-06-10 16:02:35 -0600

Seen: 759 times

Last updated: Jun 12 '12