Ask Your Question
0

MoveIt Setup Assistant, virtual joint crashes

asked 2020-09-17 04:34:39 -0500

anturtla gravatar image

updated 2020-09-17 05:59:52 -0500

Hi, I installed Moveit and its dependencies on ROS Noetic, and I am trying to follow this tutorial:

https://ros-planning.github.io/moveit...

I have both tried with panda_arm_hand.urdf.xacro and other .urdf or .xacro or .dae: no problem in generating collision matrix, but when I try to add the virtual joint the Setup Assistant window is closed with this error:

[ERROR] [1600333582.658529467]: Could not find the 'robot' element in the xml file
terminate called after throwing an instance of 'std::runtime_error'
  what():  Unable to update the SRDF Model
================================================================================REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 3186, exit code -6, cmd /home/usr/catkin_ws/devel_isolated/moveit_setup_assistant/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/usr/.ros/log/afeb18c8-f8c1-11ea-bcd2-75be2c1310bf/moveit_setup_assistant-2.log].
log file: /home/usr/.ros/log/afeb18c8-f8c1-11ea-bcd2-75be2c1310bf/moveit_setup_assistant-2*.log
Initiating shutdown!
================================================================================

Opening the file, I can definitely see the robot tag. So why does this error happen??

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-09-17 09:31:28 -0500

anturtla gravatar image

As suggested by rhaschke in the git issue, a recent fix in srdfdom package solved the problem I proposed. So to solve the problem ensure to be using at least srdfdom 0.6.2 version.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-09-17 04:34:39 -0500

Seen: 27 times

Last updated: Sep 17