Can't launch ROS node. Permissions needed? Or something else?

asked 2020-09-15 21:25:35 -0500

ajpaezm gravatar image

Hi, I tried running a node for a camera I recently bought, and this is what I got back:

... logging to /home/ubuntu/.ros/log/285605ee-f7c2-11ea-b079-a7fe99c3b3df/roslaunch-ubuntu-5280.log
Checking log directory for disk usage. This may take a while.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:40699/



 * /espros_tof_cam635/camera/averageFilter: False
 * /espros_tof_cam635/camera/channel: 0
 * /espros_tof_cam635/camera/frame_rate: 30
 * /espros_tof_cam635/camera/imageType: 0
 * /espros_tof_cam635/camera/integrationTimeGray: 10000
 * /espros_tof_cam635/camera/integrationTimeTOF1: 2000
 * /espros_tof_cam635/camera/integrationTimeTOF2: 0
 * /espros_tof_cam635/camera/integrationTimeTOF3: 0
 * /espros_tof_cam635/camera/integrationTimeTOF4: 0
 * /espros_tof_cam635/camera/interference_detection: False
 * /espros_tof_cam635/camera/interference_detection_last_value: False
 * /espros_tof_cam635/camera/interference_detection_threshold: 0
 * /espros_tof_cam635/camera/kalmanFactor: 1000
 * /espros_tof_cam635/camera/kalmanThreshold: 300
 * /espros_tof_cam635/camera/lowPowerIllumination: False
 * /espros_tof_cam635/camera/minAmplitude: 100
 * /espros_tof_cam635/camera/mode: 0
 * /espros_tof_cam635/camera/offsetDistance: 0
 * /espros_tof_cam635/camera/port_name: /dev/ttyACM0
 * /espros_tof_cam635/camera/roi_bottomY: 59
 * /espros_tof_cam635/camera/roi_leftX: 0
 * /espros_tof_cam635/camera/roi_rightX: 159
 * /espros_tof_cam635/camera/roi_topY: 0
 * /espros_tof_cam635/camera/stream: distance
 * /rosdistro: noetic
 * /rosversion: 1.15.8

    base_link (tf/static_transform_publisher)
    camera (espros_tof_cam635/tof_cam635_node)
    rqt_reconfigure (rqt_reconfigure/rqt_reconfigure)
    rviz (rviz/rviz)

It seems to load nicely at the beginning, showing configuration params and what not, but then this happens.

ERROR: cannot launch node of type [espros_tof_cam635/tof_cam635_node]: Cannot locate node of type [tof_cam635_node] in package [espros_tof_cam635]. Make sure file exists in package path and permission is set to executable (chmod +x)
ERROR: cannot launch node of type [rviz/rviz]: rviz
ROS path [0]=/opt/ros/noetic/share/ros
ROS path [1]=/home/ubuntu/catkin_ws/src
ROS path [2]=/opt/ros/noetic/share
ERROR: cannot launch node of type [rqt_reconfigure/rqt_reconfigure]: rqt_reconfigure
ROS path [0]=/opt/ros/noetic/share/ros
ROS path [1]=/home/ubuntu/catkin_ws/src
ROS path [2]=/opt/ros/noetic/share

I tried helping myself with this useful post:

So far, I tried adding "catkin_package()" to the bottom of the CMakeLists.txt, this didn't work out. I tried cd ~/catkin_ws/ and source devel/setup.bash, to no avail either.

The suggestion of chmod+x I have not tried yet. I'm not sure which files from the node need permission, if I run ls -la, I get a list of processes and their permissions level, but the only thing I see from the catkin_ws I created is the catkin_ws folder itself.

drwxrwxr-x  5 ubuntu ubuntu    4096 Sep 14 02:20 catkin_ws

If a file needs permission within the catkin_ws folder, how may I spot it?

Thanks for your help!

edit retag flag offensive close merge delete



@ajpaezm Is your node a python script? If that is the case you will need to give executable permissions to the file with: sudo chmod +x On the other hand ensure that you have sourced properly you ROS environment and Catkin workspace.

Weasfas gravatar image Weasfas  ( 2020-09-17 03:53:37 -0500 )edit

@Weasfas thank you. No, both nodes are .cpp files. Regardless, I asked the manufacturer to give me a working ubuntu image with everything set up and gladly it did.

ajpaezm gravatar image ajpaezm  ( 2020-09-23 22:01:26 -0500 )edit