Ask Your Question
1

Is rosbag python api not python3 compatible?

asked 2020-07-30 05:47:03 -0500

arunnarenthiran gravatar image

I am trying to use rosbag python api in python 3.6 and I get "modulenotfounderror: No module named 'Cryptodome' rosbag python3" error. Is rosbag python api not python 3 compatible?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-30 10:28:43 -0500

Dirk Thomas gravatar image

ROS Melodic does not officially support Python 3 but still targets Python 2.7. Only ROS Noetic targets Python 3 (and not Python 2 anymore).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-07-30 05:47:03 -0500

Seen: 20 times

Last updated: Jul 30