Symbol lookup error using move_base

asked 2020-07-24 08:27:04 -0500

flod gravatar image


I'm trying to use the move_base package in order to perform the navigation of my chefbot robot but I always get the same error :

/opt/ros/kinetic/lib/move_base/move_base: symbol lookup error: /opt/ros/kinetic/lib/move_base/move_base: undefined symbol: _ZN9move_base8MoveBaseC1ERN2tf17TransformListenerE

Running c++filt _ZN9move_base8MoveBaseC1ERN2tf17TransformListenerE returns move_base::MoveBase::MoveBase(tf::TransformListener&)

I followed the advice listed here: link text but it didn't work for me. Indeed, I had already met this kind of issue using the package move_base at the beginnig but it was an other missing "link" indicated when I had applied c++filt on the undefined symbol. I have solved it by indicating the path to the missing dependencies in the files of my /opt/ros/kinetic folder but it don't work with my current error.

When I check the dependencies between the package I'm running and the move_base package using rospack depends chefbot (chefbot is my package from which I want to launch the move base node and is in my catkin folder) or rospack depends-on move_base, the dependencies seem to be correctly built.

I also tried to rebuilt the whole package navigation from source since move_base come from it but it didn't work. I followed the advice list here for doing this : link text

I updated my system (Ubuntu 16.04, ROS kinetic). I removed all ROS packages and their dependencies, then reinstalled them with sudo apt-get install ros-indigo-desktop-full. Yet, the problem is still here.

Do somebody have an idea in order to solve this issue ?

Thanks in advance ;)

edit retag flag offensive close merge delete


I know nothing about chefbot, but are you sure you're using the proper branch of that?

David Lu gravatar image David Lu  ( 2020-07-28 08:40:00 -0500 )edit

I checked the used versions for the different package involved in my project and it is the kinetic branch everywhere I looked.

I also tried to use the move_base package with turtlebot 2 and husky (running roslaunch turtlebot_gazebo amcl_demo.launch for example) but it didn't worked and I got the same error.

flod gravatar image flod  ( 2020-07-28 08:58:24 -0500 )edit